Site Tools


Info: Rhino 4.0 Plug-ins & Visual C++ 2005 Service Pack 1

Developer: C++
WARNING: This page concerns Rhino 4.0 and may be out-of-date.

Overview

If you use Visual C++ 2005 Service Pack 1 to build plug-ins for Rhino 4.0, you will need to distribute the Visual C++ 2005 Service Pack 1 version of the C-Runtime libraries (version 8.0.50727.762) with your plug-in. Otherwise your plug-in will not load in Rhino 4.0.

You can find the Visual C++ 2005 Redistributable package for Visual C++ 2005 Service Pack 1 in the following location on your system:

C:\Program Files\Microsoft Visual Studio 8\SDK\v2.0\BootStrapper\Packages\vcredist_x86\vcredist_x86.exe

More Information

Rhino 4.0 is built using Visual C++ 2005. Thus, Rhino is distributed with the Visual C++ 2005 version of the C-Runtime libraries (version 8.0.50727.42).

Plug-ins built with Visual C++ 2005 Service Pack 1 require the version of the C-Runtime library included with Visual C++ 2005 Service Pack 1 (version 8.0.50727.762). If you try to load your plug-in on a system without these libraries, Rhino will fail to load your plug-in.

developer/sdksamples/vc2005sp1.txt ยท Last modified: 2015/09/14 (external edit)