Site Tools


Differences

This shows you the differences between two versions of the page.

Link to this comparison view

ja:rhino:meshfaq [2015/09/14]
127.0.0.1 external edit
ja:rhino:meshfaq [2016/02/16]
mmatsuo
Line 1: Line 1:
 ====== Rhinoのメッシュ設定 ====== ====== Rhinoのメッシュ設定 ======
-//​Rhinoのメッシュの設定について詳しく説明しています。また、一般的なメッシュ問題の解決方法も載せています。//+//Rhinoのカスタムメッシュの設定と利用法についての概要//
  
-//**[[http://www.hydraulicdesign.net/meshes.htm|James Carruthersによる、メッシュの表示問題についての解説(英語)もご覧ください。]]**/​/+<color slategray>​ Note: For the sake of clarity, I have condensed the original page to a quick overview of the custom mesh settings. ​ For people who want to know more, the detailed explanations are still available, ​[[rhino:meshfaqdetails|they can now be found on this page]] ​--Mitch 16.01.2013 </color>
  
-=====メッシュの問題とは===== 
  
-多くの方が下のような表示の問題を経験されたことがあると思います。+====Accessing the Meshing Settings==== 
 +The controls for the Render Mesh (display mesh) settings are part of the .3dm file's properties. In Rhino for Windows they can be reached via **File > Properties > Mesh** or **Tools > Options > Mesh**; in Mac Rhino they can be accessed via **File > Settings > Mesh**
  
-  * 滑らかな曲面のはずなのにそのように表示されない。 +They are generally set globally for the whole model, but from V4 on - including Mac Rhino - you can also override them on a per-object basis via the Properties panel. ​ 
-  * 大きなモデルの場合に表示が極端に遅くなる。 +
-  * 表示されるはずがない場所に意味不明のサーフェスが表示される。 +
-  * サーフェスまたはオブジェクト全体が表示されない。+
  
-これらのほとんどは、モデルのメッシュ生成の問題、一般的にはメッシュ設定の問題が原因です。+Rhino offers you 2 //​standard//​ settings, **//Jagged and Faster//** and **//Smooth and Slower//**, as well as **//​Custom//​**,​ which lets you access the detailed controls.
  
-「メッシュ?メッシュを作成した覚えはない。作成したのはNURBSです。」こう思われるかもしれません。 ​ +====The Standard settings==== 
 +  * **Jagged and Faster** is the default for render meshes --- fine for general visualization purposes.
  
-しかし、実際は知らない間にメッシュが作例されていたのです。下の続きをご覧ください。+  * **Smooth and Slower** offers better resolution at the expense of longer meshing times.\\ 
 +  * //(In V4, the smooth and slower setting did not work that well, in V5 it works better!)//
  
-=====メッシュが必要な理由===== +  * **Custom** allows the user the maximum flexibility in tailoring the mesh settings to their needs, at the expense of being a bit more complex to understand and set up. 
-Rhinoは[[rhino:​nurbs|NURBS]]サーフェスモデラーですが、視覚化の目的にサーフェスから作成されたポリゴンメッシュを使用します。したがって、モデルがシェーディングされる際に画面で見えるのは特別な、目に見えない、実際の[[rhino:​nurbs|NURBS]]サーフェスに添付されているポリゴンメッシュ(レンダリングメッシュ)なのです。+
  
-なぜメッシュを使用するのでしょう?それは、高速でシェーディングやレンダリングを行うためです。メッシュにはシェーディングのスピードや調整に長けています。しかしその反面、欠点もあります。レンダリングメッシュはいつもサーフェスの近似です。そのため、実際の滑らかなサーフェスと面のあるレンダリングメッシュの間に隙間がほとんどの場合できてしまうのです。+> //​**[[http://​www.hydraulicdesign.net/​meshes.htm|See also James Carruthers'​ excellent explanation of polygon meshes used for display]]**//​
  
-Rhinoの同じメッシュ生成エンジンは、ドラフト角度の解析、曲率の解析、環境マッピング機能などに用いられる解析メッシュの生成にも使用されています。また、[[rhino:​nurbs|NURBS]]オブジェクトから直接「本物の」メッシュオブジェクトを作成する**Mesh**コマンド(メッシュ > [[rhino:​nurbs|NURBS]]オブジェクトから作成)にも使用されています。 
  
-Rhinoからポリゴンベースの形式(.stlなど)を用いてエクスポートする場合も、メッシュオブジェクトが(エクスポートされるファイルに)作成されます。元のRhinoのファイルではメッシュオブジェクトは編集できませんが、同じメッシュ密度オプション設定を使用してメッシュの作成方法をコントロールすることができます。+----
  
-他のダウンストリームのプログラムやプロセスは多くの場合、作業のできるポリゴンメッシュオブジェクトを必要とするので、**Mesh**や**Export**(.stl)などの、編集できる実際のメッシュを作成する機能は多くのアプリケーションで非常に重要です。+====The Custom Settings==== 
 +<color darkslateblue>//​**If you really want to control your meshing process, here is where you need to start!**//</​color>​
  
-すべてのタイプのメッシュオブジェクトは、1つのファイルに共存でき、お互いに影響せず、それぞれが個別に特有の設定を持つことができます。すべてのメッシュは同じエンジンによって生成されますが、メッシュのタイプによっていくつかの重要な違いがあります。+When you check **Custom** in V5 (Mac or Win) you are first presented with a simple slider controlling the **//​Density//​** setting. ​ Moving it to the left will result in a fewer polygons and a coarser mesh, to the right in more polygons and a finer mesh. 
  
-=====メッシュの異なるタイプ=====+If you then push the **Detailed Controls** button in Windows Rhino, or the little **down arrow** in Mac Rhino, it will reveal all the other "​granular"​ controls that will allow you to completely control the process. ​ //In V4, the granular controls are presented directly; the //Density// setting is not available as a slider//.
  
-  * **レンダリングメッシュ**は、シェーディングやレンダリングビューポートを用いる時に、視覚化の目的で[[rhino:​nurbs|NURBS]]サーフェスやポリサーフェス上に作成されます。このタイプのメッシュは、直接にアクセス、編集はできず、メッシュの作成元の[[rhino:​nurbs|NURBS]]オブジェクトに「付着」しています。このタイプのメッシュは**ClearAllMeshes**コマンドを使うと削除できます。また、**RefreshShade**コマンドを使って、または設定を変更(ファイル > プロパティ > メッシュ)して再生成できます。(すべてのレンダリングメッシュが一度に再生成されます。)V4では、**ExtractRenderMesh**コマンドを用いてレンダリングメッシュを編集できる実際のメッシュオブジェクトに変換することもできます。+There are //seven// numerical settings and //three// check boxes. ​ Each one has a different method of mesh control and some of them can work together. ​ The interactions and combined effects of these settings are complex to understand. ​ Individually they are well described in the Help however, and reading this info carefully will give you a good idea of what each one does.  ​
  
 +[[rhino:​meshsettings|A copy of the Rhino Mesh Help page can also be found here.]]
  
-  * **解析メッシュ**は通常、編集したり、元の[[rhino:nurbs|NURBS]]オブジェクトから分離できないという点でレンダリングメッシュに似ています。メッシュのコントロールオプションが別のダイアログに表示されることと、レンダリングメッシュとは別のメッシュが作成されることが単に違います。このメッシュは、解析コマンドのダイアログボックスの「メッシュを調整」ボタンを使って、(またはプレビューボタンを使って)一時的に見ることができます。V5では、上に挙げたレンダリングメッシュのように、**ExtractAnalysisMesh**コマンドを用いて解析メッシュを実際のメッシュオブジェクトに変換することができます。+[[rhino:meshfaqdetails|Please read the companion page to this one for detailed meshing info]]
  
 +**Below is a basic start point for custom settings**, you will need to do some experimentation with them on your models. //If a setting is 0 or 0.0, it is turned off (not taken into a account).//
  
-  * **MESHコマンドによって作成されるメッシュ**は、目に見え、また編集可能です。また、元の[[rhino:​nurbs|NURBS]]オブジェクトから分離することも可能です。このタイプのメッシュは、独立したオブジェクトなので、表示され、またメッシュに使用できるいろいろなRhinoのコマンド(メッシュメニューを参照)を用いて編集することができます。また、ポリゴンメッシュ形式でSTL、DXF、3DS、OBJなどにエクスポートすることができます。 +|**Density**| ​ <color slategray>​**0.0**</​color>​| 
- +|**Maximum angle**| ​ <​color ​orangered>​**35**</​color>​|
- +
-  * **保存およびエクスポート中に作成されるメッシュ**(.stlなど)には、他のタイプのメッシュと同じメッシュ設定ダイアログ(詳細コントロール)が用意されています。またこのタイプのメッシュは、ダイアログの「プレビュー」ボタンをクリックすると一時的に見ることができます。このタイプのメッシュは、元のファイルには保存されません。(エクスポートされるだけです。) +
- +
-> <color slategray>//​**Willem(ウィレム):​** ​ エクスポートのためにオブジェクトのメッシュ生成をする際、希望する形式にエクスポートする前に私はいつも最初にメッシュを作成し、ビューポートでフラットシェーディングモード(**FlatShade**コマンド)でそれを表示します。フラットシェーディングモードは、「現在のビューポートを、それぞれのレンダリングメッシュ面が見えるようスムージングをしないでシェーディング表示します。」//​ </​color>​ +
- +
- +
-=====メッシュ設定ダイアログ===== +
-<color darkslateblue>​**//​メッシュ設定について理解しておくことは大切ですか?//​**</​color>​ +
- +
-<color darkslategray>​はい。Rhinoでメッシュ生成を最適化するために設定を理解することは大切です。そのためにこのページが用意されています。</​color>​ +
- +
-<color darkslateblue>​**//​すべてを細かく高解像度でメッシュしておくのはどうですか?そうすればメッシュ設定を理解しなくてもよいように思えますが。//​**</​color>​ +
- +
-<color darkslategray>​**//​それはよい方法ではありません。//​**</​color>​ --- かえって悪い結果になる可能性が大きいです。メッシュは画像のピクセルに少し似ています。- ピクセル//​(メッシュ面)//​が多いほど画像//​(モデル)//​の解像度は高くなりますが、その代わり画像//​(モデル)//​を表現するのにより大きなデータが必要となります。データセットが大きくなり、その上シェーディングしたモデルを回転したりすると、コンピュータがデータをリアルタイムで処理できなくなります。 +
- +
-メッシュ生成は、バランスを取る作業です。すなわち最少数のメッシュ面を使用して作業に十分使える解像度を得るということです。このことをRhinoで行うには、メッシュ生成がどのように行われるかをいくらか理解することが必要になります。//​そのためにこのページがあるのです。//​ :-) +
- +
-====The Controls==== +
-The controls for different mesh types are virtually identical. ​ The controls for the Render Mesh (display mesh) settings are part of the .3DM file's properties (**Properties > Mesh**). ​ They are set globally for the whole model, but as of V4 you can also override them on a per-object basis. ​ Rhino offers you 2 //​standard//​ settings, **//jagged and faster//** and **//smooth and slower//**, as well as **//​custom//​**,​ which lets you access the detailed controls. ​  +
- +
-When creating a mesh from a NURBS object, or exporting to a mesh format like STL, DXF, 3DS, and OBJ you can choose to use the "​simple"​ controls, which are just a coarse <==> fine slider: **fewer <==> more polygons**. +
- +
-Alternatively,​ there are the "​detailed controls"​ which expose more of the settings to the user.  They are virtually are identical for all the mesh types, and are described in detail below. +
- +
-====The Default settings==== +
-  * **Jagged and Faster** is the default for render meshes --- fine for quick visualization,​ but not very good for anything else. +
- +
-  * **Smooth and Slower** //​theoretically//​ offers better resolution at the expense of longer meshing times. In practice, even though it does take longer, frankly, it may still leave visible gaps where you don't want them, so you are advised to try the custom settings instead. +
- +
-  * **Custom** allows the user the maximum flexibility in tailoring the mesh settings to their needs, at the expense of being a bit complex to understand and set up.  +
- +
-  * The default "​simple"​ slider settings for analysis meshes as well as Mesh and Export is an average //"​somewhere in the middle"//​... +
- +
-  * The default setting for the special STL Export dialog is generally the last used //"max dist edge to srf"// setting in the custom dialog (see further on) or the value of Absolute Tolerance in File > Properties > Units if none was set. +
- +
-====The Custom Settings==== +
-<color darkslateblue>//​**If you really want to control your meshing process, here is where you need to start!**//</​color>​ +
- +
-There are //seven// numerical settings and //three// check boxes. ​ Each one has a different method of mesh control and some of them can work together. ​ The interactions and combined effects of these settings are complex to understand. ​ Individually they are well described in the Help however, and reading this info carefully will give you a good idea of what each one does. +
- +
-**[[rhino:​meshsettings|A copy of the Rhino Mesh Help page can also be found here.]]** +
- +
-==Some Quick Guidelines== +
-Below is a basic start point for custom settings, experiment with them on your models.\\ //If a setting is 0 or 0.0, it is turned off (not taken into a account).//​ +
- +
-|**Density** ​//(new in Rhino 4)//|  <color slategray>​**0.0**</​color>​| +
-|**Maximum angle**| ​ <​color ​slategray>​**35**</​color>​|+
 |**Maximum aspect ratio**| ​ <color slategray>​**0.0**</​color>​| |**Maximum aspect ratio**| ​ <color slategray>​**0.0**</​color>​|
 |**Maximum edge length**| ​ <color slategray>​**0.0**</​color>​| |**Maximum edge length**| ​ <color slategray>​**0.0**</​color>​|
-|**Maximum distance edge to surface** ​ |  **%%**%%**| +|**Maximum distance edge to surface** ​ |  ​<color orangered>​**see below**</​color>​
-|**Minimum initial grid quads**| ​ <​color ​slategray>​**16**</​color>​|+|**Minimum initial grid quads**| ​ <​color ​orangered>​**16**</​color>​|
  
-> <color slategray>​In Rhino 4, you can experiment with Density setting. ​ It is scale independent. ​ See below for a more detailed explanation of what it does.  In Rhino 3, there is no Density setting, you can insert a //scale appropriate value// in Maximum distance edge to surface. ​ For millimeter-unit models try 0.10 to 0.01</color>+Refine mesh **checked**\\ 
 +Jagged seams **//unchecked//**\\ 
 +Simple planes **//​unchecked//​**\\
  
-  * Refine mesh **checked** + 
-  * Jagged seams **//unchecked//** +  * The //maximum angle// method forces more triangles in sharply curved areas. This way small features that fall below the max distance number will be subdivided a little. You may be able to get away with a little bigger max distance number letting the angle setting take over for the smallest objects/features.
-  * Simple planes **//​unchecked//​**+
  
   * The //maximum distance edge to surface// method forces Rhino to create a mesh that is no further away from the surface than the specified value, which is in current file units. ​ It allows Rhino to put fewer polygons in lower detail areas and more polygons in higher detail areas, resulting in a more efficient mesh.   * The //maximum distance edge to surface// method forces Rhino to create a mesh that is no further away from the surface than the specified value, which is in current file units. ​ It allows Rhino to put fewer polygons in lower detail areas and more polygons in higher detail areas, resulting in a more efficient mesh.
   * The //minimum initial grid quads// setting makes sure the flatter areas have enough polygons to look smooth.   * The //minimum initial grid quads// setting makes sure the flatter areas have enough polygons to look smooth.
  
-> <color darkslategray>//​**Pascal:​** I prefer to set some largish number in "​Maximum angle" rather than zero (disabled), maybe 35-45 degrees. This way '​features'​ that fall below the max distance number will be subdivided a little. You can get away with a little bigger max distance number in some cases if you let a large angle setting take over for the smallest objects. When there is too great a discrepancy between an object and the global mesh settings, it often pays to use the Mesh command on those objects. Set the mesh to be as loose or as fine as needed for that object, then render the mesh object only, hide or delete the %%NURBS%% surface. Very small repeated details can be meshed very very loosely for instance, without impacting the quality of the image.//</​color>​ 
  
-> <color darkslategray>​//**Mitch:** I sometimes put a value of 6.in the "​Maximum aspect ratio" setting ​to keep Rhino from meshing long, thin objects with long, skinny triangles, ​it will break them up into more shorter, smaller ones.  However, this comes at the expense of bigger file sizes and sometimes significantly longer meshing times.//</​color>​+**The most important setting here is //max distance edge to surface//**. This value is in file units and is scale (size) dependent - that means you will need to adjust ​it for the size and level of detail of the objects you model.
  
-> <color darkslategray>//​**Ricardo:​** I do jewelry rapid prototyping. My default settings are 0.001 for maximum distance and 12 degrees for maximum angleLarger angles tend to show the triangle edges on the final productMesh sizes range up to 30mb on very complex modelsUnits are milimeters//</​color>​+The setting will depend on what you're going to be using your mesh setting ​for.  For general display purposes your value can be a bit bigger (coarser), as you're only visualizing ​the model on your screen, and less polygons mean faster meshing times and quicker display reaction when tumbling, zooming, etcOn the other hand, if you need to have more accurate meshing ​on very fine details for a hi-resolution render (or for manufacturing,​ perhaps), the value will need to be smaller (finer).
  
-> <color darkslategray>//​**Olivier:** I work on tensile structures that mix large membranes and steel structures. I need the membrane to be meshed accuratelybut the steel tubes   and fittings induce very heavy meshesTo deal with both big and very small curvatures, I always set a '​minimum edge length'​ to limit the number of polygons on small curvy details//</​color>​+  ​If you are doing toaster oven sized objects0.01mm (.0005 in.) generally works out pretty well
  
-**The main setting is the one for //max distance edge to surface//**If you think about it for a moment, you will understand that this value is scale (sizedependent, hence the following question:+  ​For small highly detailed objects such as watches and jewelry, try something less, maybe .002mm (.00001 in)
  
-<color darkslateblue>//​**What is a scale-appropriate value?​**//</​color>​+  ​For big objects like buildings, it can be much larger, maybe 0.1 to 1mm (.005 to .05 in) or more.
  
-First, it depends on what you're going to be using your mesh setting ​for.  For general display purposes your value can be a bit bigger (looser)as you're only visualizing ​the model on your screenand less polygons mean faster meshing times and quicker display reaction when tumblingzoomingetc.+  * If you're going to be exporting ​your object ​for later processes, or are going to be doing very detailed renderings, you may need to tighten up the settings ​a bit, depending on where it's going and how precise ​the process is.  For a stereolithography part.01mm should still be fine for examplebut for a good machined part.001mm-.002mm is probably more appropriate.
  
-  * If you are doing computer-sized objects0.01mm works out pretty well. For watches and jewelry, you will probably want it smaller, maybe .002mm. For larger ​objects ​like buildings, much larger, maybe 1mm or even larger.+It may seem a bit complicated at firstbut after a bit of practice, you will find a few standard settings that work for you in most situations These settings can even then be programmed into a macro or script to quickly launch the meshing of your objects ​with the desired characteristics.
  
-  * If you're going to be exporting your object for later processes, or are going to be doing very detailed renderings, you may need to tighten up the settings a bit, depending on where it's going and how precise the process is.  For a stereolithography part, .01mm should still be fine for example, but for a good machined part, .001mm-.002mm is probably more appropriate.+----
  
-It may seem very complicated at first, but after a bit of practice, you will find a few standard settings that work for you in most situations. ​ These settings can even then be programmed into a macro or script to quickly launch the meshing of your objects with the desired characteristics. 
  
-<color darkslategray>​Details of the **//​Density//​** setting: \\ //The Density setting in V4 uses a formula to control how close the polygon edges are to the original surface. ​ The valid range is from zero (off, or ignored) to 1, maximum density. Larger values result in a mesh with a higher polygon count. Used by itself (all other settings 0) it seems to create well balanced meshes. Density is not directly related to units or scale.//\\  +=====Other meshing problems ​and possible solutions=====
-\\  +
-//The Density number feeds Rhino something to use in its own internal calculation,​ per object, which in turn spits out a number that is like the "​maximum distance edge to surface"​ setting that is, a number in current model units that tells the mesher how far to allow the mid-point of any mesh edge to stray from the original surface. The calculation is based on the size of the object among other things. This number will be smaller as the Density setting gets closer to one. The user will never actually see this final number ​and it is different for each object being meshed. If there is also an explicit non-zero "​Maximum distance edge to surface"​ number set elsewhere in the dialog, then the mesher will use whichever number is smaller for its eventual max distance setting for each object.//</​color>​+
  
-=====Known ​meshing ​problems ​and weaknesses=====+Sometimes, you may find that even with the settings guidelines above, you are still not getting good results. ​ The meshing ​in Rhino V5 was completely re-written ​and in most cases produces much better results than earlier versions; but it may not handle all cases perfectly. Meshing is being continually improved. If you find meshing problems you can't resolve, please report them on the [[http://​discourse.mcneel.com/​category/​rhino-for-windows|Rhino support forum]] or send them to [[tech@mcneel.com|McNeel tech support]].
  
-Sometimes, you may find that even with the settings guidelines above, you are still not getting good results. ​ You may struggle with ghost surfaces, uneven shading, or triangular mesh facets that cut across empty space where they shouldn'​t be.  ​Some of these problems may be caused by the Rhino mesher'​s reaction to certain types of geometric ​structures.  ​The only way to correct them currently ​may be to do some reconstruction on your structures.+Some problems may be caused by the mesher'​s reaction to models that have hidden ​geometric ​flaws.  ​If this is the case, only way to correct them may be to do some reconstruction on the model. ​ The flaws are often located close to where the visible mesh errors show up.
  
 ====Things to watch out for:==== ====Things to watch out for:====
Line 136: Line 86:
   * <color darkslateblue>​**Bad objects.**</​color> ​ While they don't always result in mesh problems, these are easy enough to track down, so it's a good place to start. ​ If you find one, try hiding it. If your problem disappears, then perhaps all you need to do is fix the object (make it valid) and you'll be good to go.   * <color darkslateblue>​**Bad objects.**</​color> ​ While they don't always result in mesh problems, these are easy enough to track down, so it's a good place to start. ​ If you find one, try hiding it. If your problem disappears, then perhaps all you need to do is fix the object (make it valid) and you'll be good to go.
  
-  * <color darkslateblue>​**Long,​ skinny surfaces.**</​color>  ​These are hard for the mesher currently. ​ The longer and thinner, the harder it is and the longer it takes. ​ A typical example might be long continuous small radius fillets on the edges of your model. ​ If it's taking forever to mesh and you think you're geometry doesn'​t warrant that, you might also have a tiny sliver surface somewhere that's hanging up the mesh machine. +  * <color darkslateblue>​**Long,​ skinny surfaces.**</​color>  ​Difficult cases for the mesh engine in V4, this has been vastly improved ​in V5 and no longer pose problem.
- +
-  * <color darkslateblue>​**Joined tangent lines and arcs that have been extruded or revolved.**</​color> ​ Example - extruding a rounded rectangle. ​ This forms a single surface with internal G1 areas, which the mesher struggles with.  Solution - **Explode** the curves before extruding, or use **Split ​ > Isocurves** at the G1 spots to create a structure with separate joined tangent surfaces instead of one single one.  In the case of the extruded rounded rectangle, you will have eight joined surfaces, not one. +
- +
-  * <color darkslateblue>​**Kinked surfaces.**</​color> ​ Usually caused by having **CreaseSplitting** (V5 or V4 add-on) set to Noor using **MergeSrf Smooth=No** on surfaces that are not at least tangent to each other. ​ In this case, again, it is better to have multiple joined surfaces instead of one kinked one.  Use **Surface edit tools > Divide surface along creases** or **Split ​ > Isocurves** at the kinked spots to split these types of surfaces up into separate parts. +
- +
-  * <color darkslateblue>​**Triangular surfaces with holes**</​color> ​ //This is a known Rhino bug in V4.//  The "Use simple planes"​ setting (outlined above) messes up with either a triangular planar surface with a hole in the middle, or a planar surface with a triangular hole in the middle. ​ The symptom is that the hole is not displayed in shaded mode, even though it is there. ​ The remedy is to uncheck "Use simple planes"​ in the detailed mesh dialog. ​ If you are using "​Jagged ​and Faster",​ "​Simple planes"​ is checked by default and can't be unchecked, so you will have to switch to "​Custom"​ mode. +
- +
-=====Diagnostics (From the Rhino Help file)===== +
-**[[rhino:​meshdiagnostics|The Diagnostics explanation is a bit difficult to find in the Help, for your convenience it is provided here]]** +
- +
-----+
  
-===Please add your experiences!===+  * <color darkslateblue>​**Joined tangent lines and arcs that have been extruded or revolved.**</​color> ​ Example - extruding a rounded rectangle. ​ This forms a single surface with internal G1 areas, which the mesher struggles with.  Solution: **Explode** the curves before extruding, or use **Split ​ > Isocurves** at the G1 spots to create a structure with separate joined tangent surfaces instead of one single one.  In the case of the extruded rounded rectangle, you will have eight joined surfaces, not one.  In V5, you can use the **Extrude** command option **//​SplitAtTangents=Yes//** to automatically split the resulting extrusion. ​ To fix already existing cases, select the object and run the command **DivideAlongCreases > SplitAtTangents=Yes**.
  
 +  * <color darkslateblue>​**Kinked surfaces.**</​color> ​ Usually caused by having **CreaseSplitting** (native in V5 or V4 add-on) set to No, or using **MergeSrf Smooth=No** on surfaces that are not at least tangent to each other. ​ In this case, again, it is better to have multiple joined surfaces instead of one kinked one.  Use **Surface edit tools > Divide surface along creases** or **Split ​ > Isocurves** at the kinked spots to split these types of surfaces up into separate parts.
  
 +  * <color darkslateblue>​**Triangular surfaces with holes**</​color> ​ //This is a known bug in Rhino V4.//  The hole would be present in wireframe mode, but invisible in shaded mode. A "​Custom"​ mode was required to render these surfaces correctly. ​ //This has been fixed in V5!//
  
ja/rhino/meshfaq.txt · Last modified: 2016/02/16 by mmatsuo