Site Tools


我的 Rhino 4工具列都不見了!

**Rhino 5**工具列不見,請到此頁

Rhino V4工具列是儲存成一個副檔名為.tb的檔案格式,若您開啟Rhino時所有工具列都消失,這通常是因為Rhino工具列的檔案路徑遺失的關係,造成這個問題的原因很多,請依照下列方式修正:

首先,若您使用預設的工具列(default.tb),您可以著執行ToolbarReset指令,希望這個問題能夠立刻修正。

注意: 若您修改過您的default.tb,將會載入修改過的工具列,而非原始未改過的。

若您使用自訂工具列 (以另存成其他檔名),ToolbarReset 指令將會重新載入default.tb ,而非您自訂檔名的工具列。

在以上兩種狀況下,若ToolbarReset因某些原因無效,請試著依照下列方式操作:

請到 工具>工具列配置,並到 檔案 >開啟舊檔

若您於開啟舊檔對話框找不到您的工具列檔案(若您使用預設值,檔名應是default.tb),請試著依照下列路徑尋找:

  • Windows Vista, 7 或 8: C:\ProgramData\McNeel\Rhinoceros\4.0
  • Windows XP: C:\Documents and Settings\All Users\Application Data\McNeel\Rhinoceros\4.0

應可於上述路徑找到default.tb,並且也許可找到您自訂的工具列配置。

若檔案無法開啟,檔案可能已經損壞。您可以發現在同一目錄資料匣中有一個default.tb.bak 檔案,請關閉所有Rhino,刪除已損壞的default.tb檔,將default.tb.bak修改檔名,將.bak部分刪除後,重新啟動一次Rhino。

若仍然無法使用,有另一個緊急備份檔,名稱為default_backup.tb。請複製並重新命名為default.tb。

若您使用自訂工具列,並且您至少已經使用過並關閉及開啟過Rhino,那麼應該也有個.bak備份檔。若沒有,您將需要找一下您自訂工具列的備份檔案,請想想是否曾經備份過?

建議: 若您對您工具列環境配置(default.tb)有大修改,強烈建議您另存一個新檔名,重新安裝或更新Rhino可能覆蓋default.tb所有您自訂的設定。請到工具>工具列配置,點選檔案 >另存新檔,並存一個您可以辨認的名稱,將這個檔案備份起來。請思考下重新設定所花費的時間,記得好好備份,以便再度取回使用。
重要: 請確認在製作自訂工具列時,系統只開起一個Rhino畫面! 當您完成您的工具列配置時,請確認您使用工具列配置對話框上方的檔案>另存新檔儲存。或者,關閉Rhino再重新開啟。Rhino關閉時會自動儲存工具列配置的改變。若您同時開啟多個Rhino,最後關閉的狀態會複寫之前的設定,所以您自訂的工具列配置可能會遺失。
zh-tw/rhino/toolbarsdissappearv4.txt · Last modified: 2015/09/14 (external edit)