Site Tools


Online help home

Build History

Build 318 (12/12/2012)

  • Added support for *.skp files in the Textured Mesh Object.
  • Improved support for AutoCAD display of Textured Mesh Objects. Textures should appear more correct in the newer versions of AutoCAD.
  • 3d Slide Show Quality Passes/Frame increased from previous maximum of 100.

Build 315 (09/22/2012)

  • Added support for e4 on the render farm (updated the farm as well to 315).
  • Made e4 an “official” choice in the interface under Lighting→Advanced. – choices are e0 (Standard), e1 (Path Tracer), and e4 (Hybrid).
  • I now pass a frame number to RPCs during animation. This should make animated RPCs such as fountains work, but it's completely untested. Let me know if it isn't working.

Build 312 (08/17/2012)

  • Engine 4– fixed a problem with light sampling.

Build 310 (06/04/2012)

  • Added a switch to Object Properties to prevent Alpha channel through transparent objects. The global version of this switch already exists in Lighting→Advanced.

Bug Fix

  • Materials assigned to ACA 2013 components are not rendering correctly.

Build 302 (03/29/2012)

  • Compatibility with AutoCAD 2013.
  • A third experimental engine introduced. Accessible via lisp command (nxtengine 4)

Build 291 (02/13/2012)

  • Two potential new engines introduced. Accessible via lisp command (nxtengine 2) and (nxtengine 3)

Build 286 (01/30/2012)

Bug Fixes

  • Crash can occur when Save Rendering button is double-clicked.
  • Crash can occur when converting legacy material libraries.

Build 284 (01/09/2012)

Bug Fixes

  • Path Tracer– Decals in instanced blocks are not working properly.
  • Image Editor runs slowly.

Build 283 (12/10/2011)

  • Path Tracer- better handling of “black” noise in shadow areas.

Bug Fixes

  • Attaching a groundcover to multiple objects produces an AutoCAD warning “Multiply Owned Objects.”
  • Viewtwist is saved incorrectly in WalkAbout.

Build 282 (11/25/2011)

Bug Fixes

  • Color image background may cause a UI crash when first loading nXt.

Build 281 (11/22/2011)

  • Path Tracer - Daylighting significantly reworked. Most scenes should converge more rapidly.
  • Path Tracer - Alpha channel through transparent objects such as windows converges very quickly.

Bug Fixes

  • Z-Axis scale factor for complex materials is not persistent.

Build 280 (11/01/2011)

Bug Fixes

  • Crash may occur due to bad background settings.

Build 279 (10/26/2011)

Bug Fixes

  • Displacement maps not working correctly along edges or at intersection with transparent objects.
  • Path Tracer– Some alpha may be present in the pixel when transparent ray depth is exceeded.

Build 277 (10/04/2011)

Bug Fixes

  • Alpha channel may exhibit patterned artifacts in transparent objects. (Packet Tracer only.)
  • Image Editor– Combine Path Tracings… option is enabled before an image is loaded.

Build 276 (09/30/2011)

  • Added Combine Path Tracings… option to the Image Editor. (See Image→Arithmetic.) This powerful feature allows path tracings of the same scene and resolution to be combined into a single image. This single image will contain the sum of the number of passes of all the images. For example, a 500 pass image can be combined with a 250 pass image to produce a 750 pass image. Path Tracer only.
  • Single Image Path Tracings done using the Render Farm will produce low-pass single images rather than complete tiles. These must be combined into a single image using the Combine Path Tracings… option mentioned above (rather than the Add option which is used to combine Packet Tracer tiles.)

Bug Fixes

  • Render Farm– resolution is incorrect for panoramic projections.
  • Render Farm– view-based backgrounds may not render on some nodes.

Build 274 (08/30/2011)

  • Blur property added to HDRI. This blurs the visible and reflected HDRI background. It makes it possible to use lower resolution HDRIs by trading blur for pixellation. Mirror-like materials which reflect the background can sometimes appear glossy if excessive blur is used.
  • Fog can now be rendered with the render farm. Requires Build 273 of the farm.
  • Image Editor improvements including:
    • Channel names.
    • Key frame animation of Image Editor settings.
    • More Image Arithmetic choices.

Bug Fixes

  • Path Tracer: decals are not working properly when used for light source color.

Build 271 (07/15/2011)

  • Added a global switch to prevent Alpha channel masking when viewing the background through transparent objects. (Lighting→Advanced.) Most architectural applications will not want to set this switch as it will prevent alpha compositing through windows.

Bug Fixes

  • Path Tracer: transparent surfaces, including masked objects such as decals, may exhibit shadow-like artifacts, particularly when used on interiors.
  • Path Tracer: glass viewed at glancing angles may exhibit too much refraction.
  • Path tracer: total internal reflection is incorrect.
  • Path tracer: objects behind glass may be too bright.

Build 270 (07/11/2011)

Bug Fixes

  • Plant Editor may crash when opening files.

Build 269 (07/08/2011)

  • Added “Most Recently Used” file list to the File menu in the Material Editor, Image Editor, and Plant Editor.
  • Added a histogram to the Image Editor. Provides an alternate way of viewing the final display colors in an image.

Bug Fixes

  • Image Editor Arithmetic→Add may not work properly.

Build 267 (07/05/2011)

  • Changed the way intermediate views are calculated for the 3d slide show. This should allow for “plan perspectives.”

Bug Fixes

  • Displacement meshes may cause rendering to hang.
  • Blurry reflections not working due to new alpha compositing code. I had to remove alpha channel from these blurry reflections– at least for the time being.
  • Fixed some other problems relating to transparency and alpha compositing.
  • Models with displacement meshes are not being properly written out to render farm.

Build 266 (06/30/2011)

  • Reworked Alpha channel compositing for both engines.

Bug Fixes

  • WalkAbout– Wireframe display setting may not work correctly in more recent versions of AutoCAD.
  • Subdivision meshes may cause a crash.

Build 263 (06/06/2011)

  • Displacement mapping was reworked. Planar meshes should now show fewer artifacts related to triangle aspect ratio.

Bug Fixes

  • Packet Tracer– Alpha map shadows not working properly.
  • Color background not correctly excluded from alpha images.
  • Displacement maps can show incorrect internal shadowing.

Build 261 (05/25/2011)

  • Added rudimentary adaptive sampling to Path Tracer. Better convergence for most images.

Bug Fixes

  • Packet Tracer– background luminance may be incorrect when using color backgrounds.

Build 260 (05/19/2011)

  • Work continues on the Path Tracer. This build concentrates on artificial lighting, but includes some daylight improvements also. In all, faster convergence for many scenes, fewer artifacts.

Build 258 (05/02/2011)

Bug Fixes

  • Path Tracer– fixed an error in the illumination equation.

Build 257 (05/01/2011)

  • Path Tracer converges much faster for most daylit interiors. Fewer “firefly” artifacts.
  • Changed spherical mapping to work more like AutoCAD's in most cases. Cylindrical mapping hasn't changed and may differ significantly.

Bug Fixes

  • Can't grip edit ACA objects (walls, etc.) when groundplane is visible. This can cause a crash in ACA 2012.
  • Animation DB may not work properly in localized (non-English) versions of AutoCAD. This is particularly apparent when selecting paths.
  • Indirect lighting from luminaires can be assigned to an incorrect lighting channel.

Build 255 (04/25/2011)

  • Path Tracer sky illumination algorithm altered for faster convergence. Some occasional firefly artifacts may occur. Work is continuing in this area.
  • Path Tracer caustics have been improved for performance and accuracy.
  • Sub-surface scattering settings have been changed for better backwards compatibility. Default units for attenuation changed to meters. Scattering and Translucency parameters have been separated into separate properties. SSS materials created using build 254 will need to be manually edited due to these changes. This is another area of continuing work.
  • WalkAbout field of view control now includes greater precision.
  • Cylindrical decals now interpret the projection direction setting differently. Backward projection causes the decal to appear on the inside of the mapping cylinder.

Bug Fixes

  • When using the original (Packet Tracer) engine, outlines around objects may appear when using color backgrounds.
  • Mechanical objects (pipes,etc.) create in MEP 2012 may cause a crash.
  • Clipping planes may cause a crash when loading drawing.

Build 254 (03/31/2011)

  • Added Fresnel slider to the Transparency Tab (Advanced Material Editor.)
  • Lighting channel multipliers now save with .nXtImage format

Bug Fixes

  • Region Render may crash.
  • Refracted background may not display correctly in info pane of render window.
  • Ground plane not clipped in packet tracer.
  • Channel DB may crash if multipler > 5.0 are used.
  • Panorama resolution control may not work properly.

Build 253 (02/28/2011)

  • Plant Editor now uses path tracer to generate raytraced images. This improves performance quite a bit.
  • Plant Editor OpenGL display performance improved a little.
  • Sun Study DB maxima increased for some settings
  • Edit Legacy Plant DB maximum increased for diameter.

Bug Fixes

  • Plant Editor image doesn't update when window is resized.

Build 250 (01/31/2011)

Render Farm Only– Bug Fixes

  • Temporary files on node machines may not be deleted properly.

Build 249 (01/26/2011)

Bug Fixes

  • Path Tracer– Excessive “firefly” artifacts may occur. This bug was introduced in Build 248.

Build 248 (01/24/2011)

  • Added Saturation property to Highlight (specular reflection) area of Advanced Material Editor. May be useful when a reflected sky color is not desired.

Bug Fixes

  • Panoramic images may crash the Image Editor.
  • Goniometry (*.ies) File Name incorrect in the Light Properties DB

Render Farm

  • Authorize Farm applet may refuse to run.

Build 247 (01/10/2011)

  • Path Tracer: Changed the default minimum # of indirect bounces to 4, effectively disabling the user setting (I haven't grayed it out yet.) This may slow down the frame rate a little for some interiors, but should result in somewhat better convergence in shadow areas.

Bug Fixes

  • Legacy materials can contain some invalid data. This can cause a crash in the Material Editor or may result in artifacts in the Path Tracer.
  • Resolution controls for the panoramic projections are sometimes grayed out.

Build 244 (12/17/2010)

  • Added support for AutoCAD front and back (near and far) clipping planes. These are accessible in WalkAbout as well on the Special FX tab. Set these to 0.0 to disable (default.)
  • Render Farm: Included an Authorization applet to make entering your Product ID a little more straightforward.

Bug Fixes

  • Depth of field is not working proplery in the Path Tracer.

Build 242 (12/06/2010)

  • The Image Editor Depth Blur and Glare effects no longer cause pixellation. These effects are now calculated at full image resolution. Optimizations were added to compensate for the increased calculation. However, it is still possible that some slowdown will be apparent on high-res images on certain machines.
  • All Image Editor effects now operate on luminance data. Saving luminance-based formats such as .hdr or .exr will now incorporate these effects.

Bug Fixes

  • Image Editor Haze Color control is not working properly.

Build 241 (11/29/2010)

Bug Fixes

  • Spanish language version crashes when Convert Legacy Material Library… is selected.
  • Planar HDRIs not working properly when the Path Tracer engine is not used.

Build 240 (11/24/2010)

  • Path tracer– removed some optimizations to make reflections more accurate. Daylit glossy surfaces may take a little longer to resolve, particularly in interior scenes with small windows, but will be more accurate.
  • Changed the WalkAbout window so that you do not have to press the tab key after changing a value in an edit box, such as the number of pixels.
  • Added a Render Farm Folder setting to Options. This allows you to communicate with the farm without installing it on the current workstation.

Build 239 (11/15/2010)

Bug Fix

  • Path Tracer– rare path tracer crash may occur when generating caustics.

Build 238 (11/14/2010)

Bug Fix

  • Path Tracer– Extensive firefly artifacts may appear when rendering objects with glossy surfaces.

Build 237 (11/01/2010)

Bug Fix

  • Saving a Batch Rendering to an .nXtImage, .hdr, or .exr format may result in an overwrite warning, forcing the Batch process to pause.

Build 236 (10/30/2010)

  • Added planar and cylindrical projection options for hdris when selecting a custom Visible or Refractive background tabs in the main Lighting interface.
  • Added an arbitrary clipping plane custom object. Insert using the Widgets menu and orient so that the red line points towards the objects to be retained in the view. These are document-based and are active for all views provided their layer is on and thawed.
  • Changed the way the Scale parameter works on the Palm trees to bring them more in line with the other plants. Please note: this will affect current palm tree definitions and may require some manual work as a consequence.

Bug Fixes

  • Plant Editor: Leaf angle setting is not being properly saved.

Render Farm

  • Extends expiration date indefinitely. License (Product Key) will be required after 12/01 for unrestricted operation.

Build 235 (10/24/2010)

Bug Fixes

  • WalkAbout background may render incorrrectly as black.

Build 234 (10/21/2010)

  • Added a Widget to convert a standard bitmap to an hdri format. This conversion is only approximate since an hdri typically contains more information than a standard bitmap.
  • WalkAbout background choices now include *.hdr. This choice allows the use of a planar-mapped hdr for both visible and refracted backgrounds. An additional lighting channel (channel 8) is available when this type of background is used to independently control its intensity. This channel is also available in the Image Editor.
  • Updated the License Manager– please report any problems with Product Keys, etc.

Bug Fixes

  • Checking Caustics when the Path Tracer is not selected may cause a crash.
  • Explorer thumbnails not working correctly for the plants.

Build 232 (10/07/2010)

  • Added an overwrite warning if you are about to start a rendering and your previous rendering processed for 20 minutes or more. A save rendering before closing the current drawing warning has not been implemented yet. Be careful.
  • Path Tracer: Alpha transparency reworked.
  • Path Tracer: Image (framebuffer) memory requirements reduced.
  • Image Editor display and internal image should now match better.
  • Tone operator should be more stable across animation frames.

Bug Fixes

  • Path Tracer: Sky luminance is underestimated.
  • Path Tracer: Resume Raytracing is not working properly
  • Calling WalkAbout when a Paperspace viewport is active results in a crash
  • Calling WalkAbout from an mSpace viewport in paper space causes multiple problems. I've disallowed this for now.
  • Changing a material's name not working properly.
  • Internal thumbnail not displaying properly for imported, complex materials.
  • Indirect Bounce control should always be enabled for Path Tracer. (You always get two bounces, you can increase it to four.)

Build 231 (09/27/2010)

  • Added simple, “pathed” animations to WalkAbout. It's not very fancy (and not likely to get fancier any time soon)– just pick camera and target paths and go. I recommend using splines and points for paths.

Bug Fixes

  • Path Tracer: Decals may not work properly
  • Plant Editor: Crash may occur after saving a file and switching templates

Build 230 (09/25/2010)

Bug Fixes

  • RPCs not scaling properly in R17 (2008, 2009)

Build 229 (09/23/2010)

  • Initial release of foreign language versions including Spanish, French, Italian and German.
  • Added Language setting to Options DB
  • Path Tracer: “Alpha Channel” object property now working

Build 227 (09/16/2010)

Bug Fixes

  • Windows Explorer thumbnail viewer is not working properly.

Build 226 (09/10/2010)

Bug Fixes

  • Path Tracer: RGB Image or Color backgrounds not visible through transparent objects. Alpha channel is not correctly calculated for these pixels.

Build 225 (09/09/2010)

Bug Fixes

  • Material Thumbnails not displayed.

Build 224 (09/08/2010)

Bug Fixes

  • Path Tracer crashes on certain drawings.
  • Path Tracer crashes on empty drawings.
  • Some trace instability including “known issue” crash during AutoSave

Build 223 (09/07/2010)

  • The Path Tracer engine is now a checkbox on the Advanced Lighting tab. This tab is now always visible. Advanced Lighting settings which are not relevant to the Path Tracer are now grayed out when this option is chosen. The engine choice is saved with Lighting Schemes. (Lighting Schemes saved with previous builds do not contain the engine choice.)
  • The engine choice is identified in the Image Editor information DB as either 0 or 1.

Bug Fixes

  • Shadows through transparent materials may be incorrect

Build 222 (09/03/2010)

  • The installer now self-registers the product for demand-loading in all appropriate versions of AutoCAD (no appload necessary for first time loading.) Added the command “nXt” to launch the product (“ar5” still works as well.)
  • Added Blurry Transparency to the Material Editor. Useful for frosted or etched glass, etc.. The checkbox on the ME Transparency tab enables the effect. The Blurriness Slider is locked to the Highlight Sharpness Slider on the previous page, i.e. changing one changes the other.
  • Added Foliage Highlight and Translucency control to the Tree Editor.
  • Added a Path Tracer option to the Material Editor Previewer (right click.) This setting is currently not persistent (haven't decided what to do with it yet.)
  • Path Tracer: Added Orthographic and Panoramic projections.
  • Path Tracer: Added Region Render to the Path Tracer

Bug Fixes

  • nXtImage is incorrect if Channels have been manipulated during rendering
  • Hue control may crash Color Picker DB
  • Path Tracer: transparent color may be incorrect
  • Path Tracer: Channels DB doesn't work for caustics

Render Farm

  • Monitor refreshes automatically once per second
  • Beta version “date bomb” extended to 11/15.

Build 221 (08/25/2010)

High risk build warning: I've made a lot of behind-the-scene technical “plumbing” changes for this build. These include switching compilers, switching build machines, etc.. It seems to be running well (see known problem below), and the changes and bug fixes I've made are important ones for the “path tracer early implementors”– but– I would be careful about using it for production work with looming deadlines. It may be perfectly fine, but be prepared to revert to the previous version if necessary. Please report all problems.

  • I changed the path tracer algorithm somewhat with respect to glossy reflection from the sky. Convergence should be faster for many scenes. Previous versions of the path tracer may have overestimated the contribution of this light path so you may see some significant differences in some scenes.

Bug Fixes

  • Bump mapped decals not working properly in the path tracer.
  • Artificial lights may cause artifacts in the path tracer.

Known Problem

  • I'm getting a crash on 32-bit AutoCAD 2008 (Vista 32) when AutoCAD attempts to AutoSave and a rendering is in progress. The only workaround is to turn off the AutoCAD AutoSave mechanism (not the nXt AutoSave mechanism.) This isn't a test platform that I've used much in the past, so it's difficult for me to tell if this is something I've introduced with the current build or if it's been around for a while. 32-bit R18 (2010/2011) and 64 bit platforms appear unaffected by this. Please let me know if you encounter something similar on any platform.

Build 220 (08/11/2010)

  • Changed path tracing algorithm around a little. Each pass will be slower but convergence will be faster for artificial lighting cases, particularly in re: to large number of lights. Interior daylight convergence time has not been improved. Initial image display is faster in all cases.

Bug Fixes

  • Caustics in the path tracer are not correctly taking into account surface characteristics.
  • Low amplitude bump maps are not rendering properly in the path tracer.
  • Tree Editor was temporarily broken in the last build.

Build 218 (08/01/2010)

  • Added a channel control to allow adjustment during rendering.
  • Some path tracer improvements:
    • Solar highlights
    • Depth of field
    • Better glossy reflection
    • Tile texture “adjust offset” now working

Build 216 (07/21/2010)

  • Improved glossy reflection in the path tracer.
  • Added caustics to the path tracer.

Bug Fixes

  • Recoverable crash sometimes occurs when beginning a rendering after changing the resolution. Related to moving the mouse over the render screen.

Build 215 (07/08/2010)

Bug Fixes

  • IES lights are not working properly with regard to indirect lighting.
  • Path tracer does not work properly if lights have transparent covers.

Render Farm

  • Extended expiration date for unlimited free usage until 9/15. Previous build expires on 7/15. No other changes. We will be offering CD Keys for purchase soon.

Build 214 (07/07/2010)

  • First cut at a new “Path Tracer” rendering engine is available for the adventurous. Use the AutoLisp command (nxtengine 1) to switch the engine– (nxtengine 0) toggles back to the original engine. There's quite a bit to do here still– but do report any and all problems. Feel free to ask questions. I have to warn you that this is a lot more fun with a fast machine. The caustic paths are not implemented yet. Alpha objects w/ shadows are not implemented yet. Most things should work.

Bug Fixes

  • WalkAbout display does not recover mouse wheel focus when you click on the display.
  • Background preview image in WalkAbout is not correct for 2-point perspective.

Build 213 (06/06/2010)

  • Added a “Render Region” option to the WalkAbout screen. This replaces the legacy “Render Window” command.
    • Select your region by clicking and dragging (Windows' style)
    • Once a region is activated pressing the render button will render only that region.
    • If you wish to use the region render to “patch” a full-size rendering, you may have better luck doing using a native format rather than a tone-mapped image– since the tone mapping for the patch can be very different than the tone mapping for the full-size image. To do this:
      1. Make sure the resolutions of the two renderings match. It's also advisable to use the same number of passes for both.
      2. Save the output from both in .nXtImage format.
      3. Open the full-size rendering in the Image Editor.
      4. Use the Image→Patch… command in the editor to apply the patch.

Bug Fixes

  • Decals don't work when Use Object Color is checked.

Build 212 (05/24/2010)

  • Image Editor distance and materials channels now work correctly with “cutout” objects such as RPCs

Bug Fixes

  • Indirect exterior lighting does not work correctly if “cutout” objects are present. “Speckling” artifacts may occur.

Render Farm Bug Fixes (requires render farm software install)

  • Trees may cause farm nodes to render very slowly. Problem tends to manifest more when Indirect Exterior lighting is used.
  • Background bitmaps not embedding properly in data file.

Build 211 (05/15/2010)

Bug Fix

  • Textured mesh object may crash while rendering

Build 210 (05/14/2010)

  • nXt is about to expire on 5/15– sorry folks– that deadline got away from me a bit. This build extends the deadline to 7/15.
  • Added the ability to view the Material, Depth, and Alpha channels in the nXtImageEditor.

Build 209 (05/11/2010)

  • Custom textured mesh objects can be converted to native polyface meshes. This will cause loss of texture vertex info. but will permit more AutoCAD editing options. More info here.

Bug Fixes

  • Starting a rendering in a second drawing while one is running minimized in another drawing may cause a crash.
  • Autosave may cause a crash if the current path is invalid.
  • Materials may disappear from material list RPCs are present

Known Issue

  • The nXt material list (palette) does not respond well to external events such as purging of materials. For now, use the manual refresh (right-click) to synch. the list. Better solutions are being explored.

Build 208 (05/06/2010)

  • First cut at “textured mesh importer.” Currently works with *.obj and *.3ds files. Requires Acad 2008+. More (and important) info here. Save backups of your drawings until we're a little more confident with these new custom objects.
  • Added a New… option to the stand-alone material editor File pulldown.

Bug Fixes

  • Saving a complex material out of the stand-alone material editor doesn't work properly if the root of the texture tree is not selected.

Build 206 (04/19/2010)

  • Added Randomize Plant option to Widgets menu. This feature allows you to change the seed value of a plant, randomly alter its height, and/or randomly rotate the plant. Most useful for differentiating plants which have been copied or arrayed. Does not work with legacy plants or groundcover.

Bug Fixes

  • ByBlock material assignment is not working properly
  • Batch Job resolution override is not working when job is farmed.
  • Standalone Material Editor form is too short. Template control is hidden.

Render Farm Build 206

  • Render Farm Monitor now shows a little more information. Machines show which task they are currently working on. Active tasks display a progress column.

Build 205 (04/11/2010)

  • A preliminary Material Editor stand-alone application is now available. Start→AccuRender nXt→Material Editor. Please note that running either the internal or external Material Editor while a rendering is in progress will cause the rendering to proceed more slowly.
  • Incorporated the Glossy and No Light Source Reflection switches into a more general “Reflection Shader” control with additional options. See the online help for more info. The default, “Balanced” shader, has been re-tuned.
  • Added a per material control over the number of reflected bounces.

Build 205– Render Farm

  • Renderer no longer appears on the taskbar when active. All of the action is in the tray. The software has been re-plumbed a bit, so it's possible I introduced some problems.
  • True 64-bit farm download now available.
  • Help page contains a short section on updating the farm software.

Render Farm Bug Fixes

  • The Use Object Color checkbox on the Light Props DB not working properly in a farmed rendering. This affects things like computer monitors, etc..

Build 203 (04/05/2010)

Bug Fix

  • Batch processor and 3D Slide Show may pause for input after each rendering.

Build 202 (04/04/2010)

  • The Render Farm will now distribute single images generated using WalkAbout. The output from these needs to be reconstructed using the nXt Image Editor. You must update both your nXt and your Render Farm Software to build 202 for this to be possible. This means updating each node on your farm to the new software and restarting the node (you do not need to specify the shared folder again.) Even one un-updated node may cause a single image job to fail. See the online help for more details on using the Single Image option.

Bug Fixes

  • If the name of the Render Farm folder or a job sub-folder contains any spaces (“ ”) the farm job fails.
  • Several problems related to non-modal operation were introduced recently. These include the render not stopping after a render pass constraint has been entered when launched from the main AutoCAD viewport. There may still be a few kinks to work out here.

Build 201 (3/29/2010)

  • First attempt at the render farm.
    • This is a separate product, requires a separate download.
    • There is some online help with info. on installation, configuration and operation.
    • Currently only 3D Slides and Batch renderings are hooked up– more coming. Farmed 3D Slides will not work properly with RPCs. 3D Slide shows generate n -1 network tasks where n = # of slides. Batch renderings generate one network task per batch task.
    • I've only got a 32 bit version but it does run nicely on 64 bit systems. (Since it runs without the memory overhead of AutoCAD it's unlikely that you'll exceed the 3GB limit.) A true 64 bit version is coming soon.
    • I would advise not being too ambitious at first. Hooking two machines together probably makes sense as a first trial. Build slowly and don't depend on the output from this until you've had a chance to test it for robustness. It's working nicely here but it's complex enough that we may encounter some problems.
    • Render farms work best if the machines used are similar in performance. Hooking up a “slow” machine to a render farm can quickly kill any potential performance gain. Likewise slow networks and large amounts of data flying around can negate any potential performance gains.
  • Added a manual refresh to the material list in case it fails to update automatically

Bug Fixes

  • Found a couple of instances where selection sets were not being properly released. Hopefully this fixes the “selection bug” reported previously.

Build 200 (03/07/2010)

  • Implented modeless rendering.
    • Use the minimize button on the render window to enable this feature. Your rendering will continue in the background– the AutoCAD frame will become active and you can continue to work on your model.
    • You can bring your active rendering forward (recall it) in a few different ways, including the Show Current Rendering button and the Windows taskbar.
    • When the rendering is visible (not minimized) the AutoCAD frame will be disabled and the rendering will proceed modally.
    • You should be able to use almost all of the nXt functions during modeless rendering. The Material Editor will be slow due to the additional processor load.
    • Modeless rendering is available for standard AutoCAD viewport rendering and WalkAbout viewport rendering only. It is not available for CoMotion, 3D Slide Shows, Batch Rendering, and Sun Studies– at least not yet. These complex processes will proceed modally, as before.
  • Implemented modeless WalkAbout
    • AutoCAD is completely active when WalkAbout is active.
    • WalkAbout can be minimized to the taskbar and recalled using the WalkAbout button or the taskbar.
    • One WalkAbout window is created per AutoCAD document.
  • Rendering process can be continued if the current pass is allowed to be completed. If you do not allow the current pass to complete, the continue button will not be enabled.

Please note: This was a fairly tricky build with many details. It is possible, though unlikely, that you may run into problems and need to revert to a prior build to get some work done. Let me know if that occurs and you need a download link to a prior build. Please report all problems here.

accurender/nxt/documentation/build_history.txt · Last modified: 2014/06/26 (external edit)