Site Tools


Zoo 5 ne démarre pas sur les serveurs Web

Produit: Zoo 5
Résumé: Zoo 5 doit accéder au port TCP 80. Ceci n'est pas possible sur les systèmes exécutant des services Web.

Problème

Lorsque je redémarre mon serveur, le service Zoo 5 ne démarre pas. Si je consulte le Journal des événements de (Panneau de configuration → Outils d'administration → Journal des événements), je peux voir que le service Zoo 5 a enregistré une erreur :

Le service Zoo 5 sur l'ordinateur local a démarré puis s'est arrêté. 
Certaines services s'arrêtent automatiquement s'ils ne sont pas utilisés par un autre
service ou programme. 

En regardant les détails de l'erreur, toujours dans le journal des événements, on trouve :

Adresse en cours d'utilisation par un autre processus.
Lancer 'netstat -o -n -a' dans une invite de commande pour déterminer
l'ID du processus conflictuel, puis regarder dans le Gestionnaire des tâches afin de trouver le nom de ce processus. 
  1. Lancez NETSTAT -ano dans l'invite de commande et notez le numéro PID du port ouvert que vous voulez libérer.
  2. Dans le Gestionnaire des tâches vous pouvez voir à quel processus correspond le PID et vous pouvez déterminer quel programme utilise ce port.

Cette erreur est due à l'utilisation du port 80 par une autre application. Une seule application ne peut écouter un port à un moment donné et le Zoo ne peut donc pas se connecter au port 80. Applications les plus communes causant cette erreur :

Résolution

  1. Déplacez le Zoo sur un ordinateur n'exécutant pas de services Web. Ce peut être un serveur d'impression, un autre ordinateur qui reste toujours allumé ou un serveur virtuel supplémentaire.
  2. Configurez les services web afin qu'ils utilisent un autre port. Apache et IIS peuvent tout deux être configurés pour s'exécuter sur une autre port.


fr/zoo/webserverport80.txt · Last modified: 2015/09/14 (external edit)