Site Tools


Lo Zoo non si avvia sui server Web

Prodotto: Zoo
Sommario: Lo Zoo richiede l'accesso alla porta TCP 80. Ciò non è possibile nei sistemi con servizi Web in esecuzione.

Problema

Quando riavvio il server, il servizio dello Zoo non si avvia. Se verifico il registro eventi di Windows (Pannello di controllo → Strumenti di amministrazione → Registro eventi), vedo che il servizio dello Zoo ha registrato un errore:

The Zoo service on the Local Computer started and then stopped.
Some services stop automatically if they are not in use by another
service or program.

Esaminando i dettagli di questo errore, sempre nel registro eventi di Windows, appare il seguente messaggio:

Address already in use by another process.
Run 'netstat -o -n -a' from a command line to find the conflicting
process ID, then look in Task Manager to find the name of that process.
  1. Eseguire NETSTAT -ano dalla riga di comando ed annotare il numero PID della porta aperta che si vuole liberare.
  2. Da un gestore dei processi (task manager), si può vedere a che processo corrisponde il PID e quale programma sta usando quella porta.

Il motivo di questo errore è che un'altra applicazione sta già usando la porta 80. Una porta può essere utilizzata solo da un'applicazione alla volta, per cui lo Zoo non riesce a collegarsi alla porta TCP 80. Applicazioni comuni che causano il problema:

Soluzioni

  1. Spostare lo Zoo su una macchina che non stia eseguendo servizi Web. Può essere un print server, un'altra stazione di lavoro lasciata accesa oppure un altro server virtuale.
  2. Configurare i servizi Web in modo che usino porte diverse. Sia Apache che IIS si possono configurare affinché usino porte diverse.


it/zoo/webserverport80.txt · Last modified: 2017/05/04 by elenac