Site Tools


My toolbars disappeared ! - Rhino V4

For disappearing toolbars in **Rhino V5**, look here instead

The toolbars in Rhino V4 are stored in an external file with a .tb extension (sometimes called a workspace file as well). If your toolbars are no longer there when you open Rhino, this is usually due to the fact that Rhino has “lost” the path to the toolbar file. It may be due to a variety of problems… The following will almost always fix it:

First, if you are using the default workspace (default.tb), you can just try running the ToolbarReset command. Hopefully this will fix the problem immediately.

Note: If you have modified your default.tb, it will load the modified one, not the original unmodified one.

If you are using a custom workspace (one that has been saved under a different file name), the ToolbarReset command will likely not be what you want, as it will re-load the default.tb.

In either of these cases, or if ToolbarReset didn't work for some reason, try the following:

Go to Tools > Toolbar Layout, and choose File > Open.

If you don't see your toolbar file in the open dialog (it will be default.tb if you're using the default toolbar layout), try navigating to the following folder:

  • Windows Vista, 7 or 8: C:\ProgramData\McNeel\Rhinoceros\4.0
  • Windows XP: C:\Documents and Settings\All Users\Application Data\McNeel\Rhinoceros\4.0

You should find the default.tb in there, as well as perhaps your custom workspace if you saved it there originally.

If after this your workspace still refuses to open, it may be corrupted. If it is the unmodified default workspace you are using (default.tb), you will find a default.tb.bak in the same directory. Close all instances of Rhino, remove the corrupted file and remove the .bak part of the extension try again.

If that STILL doesn't work, there is another emergency backup named default_backup.tb. Make a copy of that and try renaming it to default.tb.

If you are using a custom workspace and you have opened and closed Rhino at least once while using it, there should also be a .bak of that too. If not, you will need to retrieve your backup copy of your custom workspace that you have stored elsewhere. You DID make a backup copy, didn't you?

ADVICE: If you have modified the default workspace (default.tb) in any significant way, it is highly recommended that you save it under a new name. New installations or updates of Rhino can overwrite the default.tb, wiping out ALL your customization in an instant. Go into into Tools > Toolbar Layout, hit File > Save As and give your modified workspace a recognizable name. Always do all your modifcations on your custom workspace. Save this file somewhere else as well as a backup (preferably on another computer like all important documents). Think of how much time it will take you to re-create it if you lose it.
IMPORTANT: Make sure only one instance of Rhino is open when making toolbar/Workspace modifications! Once done with your toolbar installations, make sure you use File>Save from the toolbar layout dialog to save your changes! Or, exit Rhino and re-open. Rhino saves toolbar changes automatically on exit. If you have multiple instances of Rhino open, the last one to close will overwrite the previous one, so you might lose your changes.
rhino/toolbarsdissappearv4.txt · Last modified: 2014/06/26 (external edit)