Site Tools


FAQ sobre mallas

Opciones de malla de Rhino

Resumen: Revelación de los misterios de las opciones de malla de Rhino. Solución a problemas comunes de mallado.
Nota: ¡No dude en contrinuir y compartir su experiencia sobre mallado y secretos de configuración! Si tiene una configuración de malla de exportación específica de un programa, se puede crear una página para ello.

¿Por qué necesito las mallas?

Aunque Rhino es un modelador de superficies NURBS, utiliza mallas poligonales creadas a partir de esas superficies para fines de visualización, de modo que lo que se ve en la pantalla cuando se sombrea el modelo es en realidad una malla poligonal invisible (la “malla de renderizado”) de la superficie NURBS.

¿Por qué? Para que el sombreado y el renderizado sean más rápidos. Pero mientras que una malla tiene las ventajas de velocidad de sombreado y ajustabilidad, hay un inconveniente. La malla de renderizado siempre es una aproximación de la superficie, de manera que siempre hay vacíos entre la malla de renderizado con facetas y la superficie suave real.

El mismo motor de mallado en Rhino se usa en la creación de mallas de análisis para funciones como Análisis de desmoldeo y Análisis de curvatura, MapaE, etc. y lo usa el comando Malla (Herramientas > Malla poligonal > Desde objeto NURBS), que crea un objeto de malla “real” directamente a partir de un objeto NURBS.

La exportación desde Rhino con determinados polígono basados en polígonos (como .stl) también crearán objetos de malla (en el archivo exportado). Aunque no se pueden editar en el archivo original de Rhino, tiene el mismo grupo de opciones de densidad de malla para controlar cómo se crearon.

Las funciones que crean mallas reales editables como los comandos Malla y Exportar (.stl) son muy importantes en muchas aplicaciones.

Todos los tipos de objetos de malla pueden existir simultáneamente en un archivo, no repercuten uno en otro y cada uno puede tener su propia configuración. Aunque todas las mallas se crean con el mismo motor, hay algunas diferencias importantes entre ellas.

Los diferentes tipos de mallas

  • Las mallas de renderizado creadas en las superficies y polisuperficies NURBS para fines de visualización (utilizando la vista en modo sombreado o renderizado) no son editables ni accesibles para los usuarios y no se pueden separar del objeto NURBS desde el que se crearon. Se pueden eliminar con el comando BorrarTodasLasMallas y regenerar con el comando “ActualizarSombreado” o cambiando la configuración (en Archivo > Propiedades > Malla) (que obliga a hacer una regeneración global de todas las mallas de renderizado).
  • Las mallas de análisis son similares a las mallas de renderizado en el hecho que no son editables y que no se pueden separar de su objeto NURBS. Simplemente tienen otro grupo de controles y están separadas de las mallas de renderizado. Sin embargo, puede “verlas” temporalmente cuando utilice el botón “Ajustar malla” o el botón “previsualizar” en el panel de configuración de los cuadros de diálogo de los comandos de análisis.
  • Las mallas creadas con el comando Malla se pueden ver y editar, y están separadas de los objetos NURBS desde los que fueron creadas. Son objetos y se pueden ver y editar con los diferentes comandos de Rhino que se aplican a las mallas (véase Bonus > Malla) y se pueden exportar en los formatos de malla poligonal como STL, DXF, 3DS y OBJ.
  • Las mallas creadas durante Guardar y exportar (como .STL tienen la misma configuración de malla (“Opciones detalladas”) que los otros tipos. También puede verlas temporalmente cuando utilice el botón “previsualizar” en el panel de configuración, pero no se guardan en el archivo original (sólo exportados).

Willem: Al mallar un objeto para exportar, siempre creo primero una malla y lo veo en la vista en modo Sombreado plano (comando SombreadoPlano) antes de exportarlo al formato deseado. El modo de Sombreado plano sombrea la vista actual sin suavizado, de manera que las caras de las mallas de renderizado individuales están visibles“.

Los diálogos de la Configuración de malla

Los controles de los diferentes tipos de malla son virtualmente idénticos. Los controles de la Configuración de malla de renderizado son parte de las propiedades del archivo 3DM, son globales para todo el modelo. Al exportar a un formato de malla como STL, DXF, 3DS y OBJ, alternativamente puede usar controles simples, como un control deslizante. Los controles detalladas son idénticos para todos y se describen más abajo.

La configuración de la malla de renderizado se encuentra en Archivo > Propiedades > Malla. Rhino ofrece dos configuraciones “estándar”, “dentada y más rápida” y “suave y más lenta”, además de la configuración “personalizada”, que permite acceder a las opciones detalladas. Las opciones “simples” aparecen cuando se ejecuta el comando y simplemente se trata de un control deslizante: menos ↔ más polígonos. Las “opciones detalladas” de los demás son iguales.

Valores predeterminados

La opción predeterminada para las mallas de renderizado es “Dentada y más rápida”, que está bien para la visualización, pero no para mucho más.

La opción “suave y más lento” ofrece teóricamente una mejor resolución con mayor tiempo de mallado, pero a la práctica, aunque tarda más, suele dejar agujero visibles, de manera que es mejor probar la configuración “personalizada”.

La configuración predeterminada de las “opciones simples” para las mallas de análisis y de exportación están “más o menos en medio”…

El valor predeterminado del diálogo de exportación STL especial es el valor de la tolerancia absoluta de Archivo > Propiedades > Unidades.

Configuración personalizada

Si quiere controlar su proceso de mallado, debe empezar por aquí.”

Hay siete configuraciones numéricas y tres casillas de verificación. Cada uno tiene un método diferente de control de mallas y algunos pueden interactuar. Las interacciones y los efectos combinados de esas configuraciones son difíciles de comprender. Individualmente están bien descritas en la Ayuda y leer esa información atentamente puede ayudarle a comprender mejor qué es lo que hace cada una.

Algunas instrucciones rápidas

A continuación se muestran algunas configuraciones que han funcionado, con las que puede experimentar.

Personalmente, utilizo las siguientes opciones detalladas de malla:

Densidad (nuevo en Rhino 4)
Ángulo máximo0.0
Relación de aspecto máxima
es/rhino/meshfaqdetails.txt · Last modified: 2015/09/14 (external edit)