Site Tools


Toucan Materials - Obsolete

:!: WARNING: Toucan is not currently in development and should be considered obsolete.

Using and editing materials for the Toucan renderer on Rhino for Mac uses two different windows. The Toucan material browser displays materials in the standard material libraries, and also displays the materials in all the open drawings. A second window, the material editor, lets you modify the attributes of a Toucan material.

Over time, you will accumulate a library of Toucan materials. When preparing to render a drawing, you will use the material browser to select materials from your library and apply them to objects in your drawing. You may choose to tweak some of the attributes of the materials in your drawing and you can do that directly to the material placed in the drawing. You can also copy back the modified material into your library so you can use it in other render projects.

Toucan Material Browser

Rhino for Mac dedicates a window to browsing materials. This window shows all the accessible Toucan materials, and you use this window for applying materials to a drawing.

 Icon view

Icon view

List view

The browser has two views of the Toucan materials, icon view and list view. Choose the view using the buttons in the toolbar at the top of the window.

Search by name

You can search the materials by name by typing a search value in the Search box at the top of the window. Only the materials whose name matches the search string will be displayed. The Search value is persistent; erase the contents of the Search field to again display all the materials.

A slider at the bottom of the window adjusts the size of the material preview image.

Material Sources

The left column of the browser window lists the available sources of Toucan materials. Personal Library contains your customized collection of materials and is initially empty when you start using Toucan. Toucan Library is a collection of standard materials shipped with Rhino for Mac. You may use these materials in Rhino drawings, but they are standard materials and may not be edited. Other Materials on 'Machine' lists Toucan materials found elsewhere on your computer. If you have copied materials to other directories, they will appear in this library.

The material browser also displays the Toucan materials contained in each open Rhino document.

toucandrawingmaterials.jpg

Materials in drawing
(click for larger view)

The is a section in the left had column for each open drawing. You can display the materials from one drawing and have a different drawing active.

Applying Materials

Toucan materials are applied to objects in a Rhino drawing by dragging a material icon in the right hand side of the material browser and dropping the material on top of the desired object in the drawing.

toucanapplymaterial.jpg

Applying a material
(click for larger view)

As you drag a material over a drawing, the object directly under the cursor is highlighted and this is the object that will receive the material when you release the mouse button. If you drop the material when no object is highlighted, the material slides back to the material browser, indicating that the material drop was not successful.

You can apply a material to more than one object at a time. Preselect all the objects that will receive the material. Drag the material from the browser to the drawing until the material is over one of the selected objects. When the material is over one of the selected objects, the highlight for all the selected objects changes. Drop the material on one of the selected objects to apply the material to all selected objects. If you do not drop the material on a selected object, the material slides back to the material browser, indicating that the material drop was not successful.

toucanmaterialapplied.jpg

Material applied
(click for larger view)

After dropping the material, the material is applied to the selected object and the Rhino view updates to show the application of the material. The new material will also show up in the browser list of materials for that drawing.

You can apply materials from any of the sources listed in the left hand column in the material browser. You can apply materials from any of the libraries, and you can also apply a material contained in one drawing directly to an object in another drawing. Toucan materials can be stored in a disk file and they will have a .tmf extension. You may also drag a Toucan material file from the Finder and apply it to an object in a Rhino drawing.

Exporting Materials

You can export a material to a folder on your computer from a library or from a Rhino drawing by dragging the material icon from the right hand side of the browser to the destination folder.

Export material
(click for larger view)

The cursor indicates that you will make a copy of the material by showing a green ball containing a plus symbol (the “copy” indicator). When you release the moue button, the material will be copied to a file in that folder.

Importing and Copying Materials

Likewise, you use drag and drop to import materials into your Personal Library and into any open document. Simply drag a material from a Finder folder and drop it onto the left hand column. The “copy” indicator is displayed when the cursor is over a valid destination. Release the mouse to drop the material and copy it to the destination. If you hover over a valid destination while holding down the mouse button, that destination will open in the right hand side of the browser. You can then drop the material on the right panel.

Materials in the Toucan Library may not be edited. You must first copy the Toucan Library material you wish to change into your Personal Library or into a Rhino drawing. Select the Toucan Material library section, then drag the desired material from the right hand side and drop it on the desired destination in the left hand list.

Inspecting Toucan Library Materials

Materials in the Toucan Library cannot be edited, but you can inspect the material attributes. Double click on a material in the Toucan Library to see the attributes. Alternatively, select “Inspect Material” from the context menu.

Inspect Toucan Library material

Note: Double click does not work when the browser is in icon view. Also, the context menu is not working in icon view in the first WIP release.

Editing Materials

All other Toucan materials can be edited. Double click on the material (list view only) to bring up the Toucan Material editor.

Edit material

This dialog displays the common material attribute settings in five sections. Each disclosure triangle shows or hides the contents of the section. The checkbox enables or disables the attributes in the corresponding section. As you make changes to the attributes, the preview at the top of the window is updated.

By default, all the sliders adjust the attribute value between 0.0 and 1.0. This is often, but not always an appropriate range for an attribute value. You may also enter any value you would like into the value field. The slider is there merely as a convenience.

Save your material changes by selecting File > Save in the application menu or by typing the menu shortcut ⌘S. The material browser preview will update and, if you are editing a material in a drawing, the preview in a Rendered viewport will also update.

You can also save your changed material as a file by selecting File > Save As… in the menu.

Creating new materials

Clicking the Plus button at the bottom of the browser will create a new default material. Double click on the material (in list view) to edit it. Edit the material name field at the top of the editor window to change the material name.

Alternatively, you can create a new material by using an existing material as a starting point. Select a material in your Personal Library or in a drawing, then select Duplicate Selected Material in the context menu. Another material will appear in the section and you can edit it, including changing the material name.

Deleting materials

Delete a material in your Personal Library or in the Other Materials library by dragging the material to the Trash. You may not delete materials in the Toucan Library, and you cannot yet delete Toucan materials in a drawing.

Advanced Editing

The material editor initially displays the common material attributes, but there are many more material attributes available in Toucan materials. To see all the attributes, select Show More Settings in the action button at the bottom of the editor window.

The editor will then display all the possible material attributes.

Advanced material settings

Now there are six major sections of attributes and many subsections of attributes. Many of the attributes can have textures added to them by using the gear menu to the right of the attribute (not implemented in the first WIP release). If you set attributes that are only visible in the More Settings view, these settings will still be displayed next time you edit this material - you do not have to select More Settings each time you edit your new material.

Other Features

Rhino includes a QuickLook generator for Toucan materials, so you can view the materials in the Finder.

toucanquicklookcoverflow.jpg

Coverflow view
(click for larger view)

toucanquicklookicon.jpg

Icon view
(click for larger view)

Known problems

Some of the features are not yet implemented. In fact, some were discovered as this document was written and after the WIP release was created!

  • Browser context menu should contain Edit Material / Inspect Material choice.
  • Browser context menu Select objects using the selected materials does not work.
  • Closing a drawing before closing unsaved materials will probably crash when saving the material.
  • Autosaving a Toucan material does not work and may crash Rhino. Do not leave the Toucan material editor open with unsaved changes.
  • The browser context menu in icon view is missing.
  • You cannot delete a material in a drawing.
  • The Default Material is not always displayed in the browser.
  • You cannot add or delete textures in the material editor.
rhino/mac/toucanmaterials.txt · Last modified: 2015/09/14 (external edit)