Site Tools


The nXt Render Farm

A render farm is a group of networked computers working together to complete large rendering tasks. Normally, render farms proceed silently, without graphically displaying the renderings as they progress. Rendering in this manner lets you to use more computer power for lengthy tasks, at the expense of some interactivity.

Many third-party render farm products are currently available. The nXt Render Farm software lets you to work with one of these, or you can set up a simple render farm just using the software provided. The nXt Render Farm software is sold separately from the nXt platform plug-ins such as Flaminog nXt. The software itself is platform independent – Rhino is not required on computers used only for render farming.

The nXt Render Farm includes two basic pieces of software:

  1. nXtFarmer.exe (nXtFarmer64.exe) is a small program that runs on each network rendering station and waits for jobs to be generated.
  2. nXtFarmMonitor.exe (nXtFarmMonitor64.exe) is an applet that shows you the state of your render farm and provides some simple control tools.

The following procedures apply to nXt's included render farm. If you are planning to use third-party render farm software, some of these procedures will be different.

Installing and configuring the Render Farm

Create a shared folder for use by the Render Farm. All the network rendering computers must have read/write access to this folder. The shared folder should have lots of available disk space to store both data (input) and images (output). We recommend 20-200 GB available storage. You must perform the following four steps on each computer you plan to use in the Render Farm. This includes any nXt workstations which submit jobs to the Render Farm.

  1. Install the nXt Render Farm software.
  2. From the Start menu, run the Render Farmer on each machine. The Render Farmer will appear as an icon in the system tray.
  3. Right click on the icon and select Restore. A window title nXt Farmer should appear.
  4. Select Options→Path… from the menu and select the path to the render farm. You can now minimize the Farmer window to the tray.

The Render Farm is now configured. To verify that the farmer machines are responding run the Render Farm Monitor from the Start menu on any of the workstations. The machines should appear in the upper list box. If you wish to exclude a machine from participating in the render farm, you can select it, right click, and choose Suspend.

Updating the Render Farm software

All participating computers must be updated before a new job can be submitted to the farm. Use the following procedure:

  • Wait for any active farm jobs to complete before beginning your update.
  • For each participating computer:
    1. If the Render Farm is currently running, close down the Render Farmer by right-clicking on the tray icon and selecting Close.
    2. Install the nXt Render Farm software.
    3. Run the Render Farmer from the Start Menu. The tray icon should appear.

Licensing the Render Farm

The evaluation version of the Render Farm lets two network machines (nodes) work on jobs simultaneously. If you wish to have more network nodes running simultaneously you can buy an unlimited node license here.

Once you have purchased your license and have acquired a Product Key, use one of the following procedures to license your farm.

Post-build 244 procedure (recommended):

  1. Wait for any active farm jobs to complete before beginning your licensing.
  2. Save your Product Key to a network location so you can cut and paste it into each node.
  3. For each participating computer:
    1. If the node is currently active, shut it down by right-clicking on the Render Farm tray icon, and selecting Close.
    2. Run the Authorize Farm applet from the nXt Render Farm folder in the Start Menu.
    3. Paste in your Product Key and select OK. A message box indicating success should appear. If an error condition is indicated the licensing procedure has failed and tech support may be necessary. Click OK.
    4. Start the node by selecting Render Farmer from the nXt Folder of the Start Menu.

Pre-build 244 procedure:

  1. Wait for any active farm jobs to complete before beginning your licensing.
  2. Shut down all network nodes first by visiting each machine, right-clicking on the Render Farm tray icon, and selecting Close.
  3. Save your Product Key to a network location so you can cut and paste it into each node.
  4. For each participating computer:
    1. Run the Render Farmer from the Start Menu. The tray icon should appear.
    2. Right click on the icon and select Restore.
    3. Select Options→Enter Product Key…
    4. Paste in your Product Key and select OK.
    5. Shut down the node by closing the window.
  5. Once all computers are licensed you can restart each node.

To verify that you are now running a licensed copy, view the About… box:

  1. Right click on the tray icon and select Restore.
  2. Select Help→About… to view the About box.
  3. The word Evaluation should not appear after the version number. (If the version number indicates an Evaluation version, licensing has not been successful and tech support may be neccessary.) Click OK.
  4. Minimize the Render Farmer window to return it to the tray.
ko/flamingo/flamingofarm.txt · Last modified: 2018/08/29 by bob