Site Tools


Importing New Toolbars Into Your Workspace

Important: Do all this with only one instance of Rhino open at a time! Once done with your toolbar installations, make sure you use File>Save from the toolbar layout dialog to save your changes! Or, exit Rhino and re-open. Rhino saves toolbar changes automatically on exit. If you have multiple instances of Rhino open, the last one to close will overwrite the previous one, so you might lose your changes.

Download the toolbar file (.tb) you want. Place it on your hard drive somewhere you can find it. The easiest place is probably the same folder where your normal or default workspace resides. Then, from inside Rhino, go to Tools > Toolbar Layout. In the dialog click Toolbar > Import and browse to the toolbar you want and click Open.

The dialog will show a list of toolbars contained in the file (there can be one or many). Check the boxes next to the ones that you want to import (otherwise nothing will be imported) and click Import. The toolbar is now a permanent part of your workspace! Before closing the toolbar dialog, scroll down the list to find your new toolbar and check the box so it will show, then close the dialog.

You can then put the toolbar where you want it and use it like that. Or, you can move or copy the buttons from the imported toolbar to existing toolbars, and having done so, discard the original.

Opening a new workspace or toolbar

Opening is different from importing in that the toolbar or workspace doesn’t become part of your current workspace. It resides separately. From Rhino V3 on, you can have multiple workspaces open simultaneously. A workspace, otherwise known as a toolbar collection (also a .tb file), can have one or many toolbars, each with one or many buttons.

The procedure is essentially the same as above, except once that you get into the Toolbar layout dialog, click File > Open (not Toolbar > Import). Browse to the .tb file you want and click Open. Then exit the toolbar dialog. Arrange the newly opened toolbar or workspace as you want. It will co-exist with the others. This will remain open even between Rhino sessions, unless you go back into the toolbar dialog and close it again.

Copying or moving buttons from one workspace to another will permanently import them. So this is another way to import a toolbar –- simply open the .tb file with the toolbar dialog, copy or move all the buttons into your current workspace, then close it again.

Advice: If you have changed the default workspace (default.tb) in any significant way, we highly recommend that you save it under a new name. New installations or updates of Rhino can overwrite the default.tb, wiping out all your customization in an instant. Go into into Tools > Toolbar Layout, click File > Save As and give your modified workspace a recognizable name. Always do all your modifications on your custom workspace. Save this file somewhere else as well as a backup (preferably on another computer, like all important documents). Think of how much time it will take you to recreate it if you lose it.

Exporting one or more toolbars

It is also possible to export toolbars or toolbar collections so that you can share them with someone else.

If you have only one toolbar with only a few buttons to export, the easiest way is:

In the toolbar dialog, click New, in the browse box, give the file a name and save it somewhere. (Suggestion: Name the file the same as you're going to name the toolbar you're exporting.) You're actually going to be creating a workspace of one toolbar.

While still in the toolbar editor, you should now notice that you have the new workspace open. If you click on it, you will see that it is blank, i.e. there no toolbars in it – yet. So, while it is highlighted, click Toolbar > New to make a new toolbar and name it. It will have one blank button.

Now, with Ctrl+LMB, drag-copy all the buttons you want from your existing workspace onto the new toolbar. Delete the one blank button. Open the toolbar dialog once again and Save the new workspace.

That's it. You can now locate your new workspace file where you have saved it. It will have your one newly created toolbar in it. You can share this file with a friend. They can either use Import to import the whole toolbar at once, or just open it in parallel with their existing workspace and drag the buttons over.

Don't forget, if there are external references or scripts to send those as well…

If you want to export several bigger toolbars, then it's generally easier to:

Again, in the toolbar dialog, click New, in the browse box, give the file a name and save it somewhere (this is your export file).

While still in the toolbar editor, you should now see the new workspace. Click on it to highlight it, and click Toolbar > Import. Browse to your normal workspace file (the one you want to export the toolbars from), and follow the procedure at the top of the page to import as many toolbars as you want from your existing workspace into your new (export) workspace. When done, while the export workspace is still highlighted, click File > Save. At this point your export workspace will include all the toolbars you transferred.

rhino/toolbarimports.txt · Last modified: 2016/05/17 by sandy