Site Tools


Transférer les Paramètres personnalisés

Comment transférer tous vos paramètres personnalisés d'une installation vers une autre

Où sont enregistrés mes paramètres ?

Dans Rhino 5 et les versions précédentes la plupart des paramètres de Rhino n'étaient pas enregistrés dans des fichiers externes, mais dans le registre. Dans Rhino 6, la plupart de ces informations ont été retirées du registre pour les placer dans un ou plusieurs fichiers de paramètres au format .xml. Cependant, dans les deux cas, il n'existe pas de fichier unique contenant toutes les options et personnalisations, le transfert de vos paramètres personnalisés ne se fera donc pas en un seul clic. Il existe toutefois des raccourcis :

La façon la plus simple de transférer la plupart de vos paramètres est d'utiliser la commande de Rhino ExporterOptions qui créer un fichier unique avec _la plupart_ des personnalisations. L'importation de ce fichier dans une autre installation avec la commande ImporterOptions transférera les paramètres vers la nouvelle installation. Vous avez la possibilité de choisir les paramètres que vous voulez importer. Il n'est pas obligatoire de tous les importer.

Remarque : Les modes d'affichage ne sont pas inclus dans la commande ExporterOptions de la version 4, vous devez les exporter à part. Pour ce faire, ouvrez les Options > Apparence > Paramètres avancés.

Pour les modes d'affichage, ils sont inclus sous forme d'ensemble dans ExporterOptions et ImporterOptions depuis la version 5, cependant, vous ne pouvez pas sélectionner lesquels sont pris en compte. Si vous voulez juste transférer des modes d'affichage de manière individuelle, utilisez les boutons Exporter/Importer dans Options > Vue > Modes d'affichage.

Séparés des autres options, les fichiers d'espace de travail contiennent la plupart des informations sur les barres d'outils/boutons telles que l'emplacement des boutons dans les barres d'outils, les macros de commandes de chaque bouton et les images. Les fichiers d'espace de travail ont une extension .tb pour la version 4 et .rui à partir de la version 5. Vous pouvez également copier ce fichier entre différentes installations. À partir de la version 5, l'emplacement par défaut de ces fichiers est un dossier caché :

C:\Users\<nom de l'utilisateur>\AppData\Roaming\McNeel\Rhinoceros\<numéro de version>\UI

(<nom de l'utilisateur> représente votre nom d'utilisateur dans Windows, <numéro de version> peut être 5.0, 6.0 etc.)

Remarque : Vous pouvez accéder rapidement à ce dossier en cliquant sur le bouton démarrer de Windows et en tapant %appdata% suivi de la touche Entrée afin d'atteindre le dossier Roaming, puis en navigant jusqu'au dossier indiqué.
Pour la version 4, les barres d'outils se trouvent dans le dossier : C:\ProgramData\McNeel\Rhinoceros\4.0 (Win Vista et suivantes) ou : C:\Documents and Settings\All Users\Application Data\McNeel\Rhinoceros\4.0 (XP)

Le fichier d'espace de travail ne contient pas la position des barres d'outils sur l'écran mais uniquement leur contenu et si elles sont ouvertes ou non. Dans la version 5, les informations sur la position des barres d'outils sont enregistrées dans le registre ; dans la version 6 elles se trouvent dans un fichier de paramètres .xml placé dans le dossier :

C:\Users\<nom de l'utilisateur>\AppData\Roaming\McNeel\Rhinoceros\6.0\settings

Le fichier .xml contenant les options mentionnées au début se trouve dans le même dossier.

D'autres éléments peuvent être personnalisés ou modifiés, comme les fichiers modèles, les modules installés, etc. Les fichiers modèles sont de simples fichiers .3dm et peuvent donc être copiés d'un ordinateur à un autre sans problème ; les modules devront probablement être réinstallés ; attention aux problèmes de compatibilité si vous faites une mise à jour de la version de Rhino.

Comment être sûr de ne rien oublier ?

En règle générale, si vous devez transférer une installation, vous pouvez suivre cette procédure :

Sur l'ancienne installation :

Utilisez la commande ExporterOptions pour créer un fichier .ini

  • Copiez votre fichier d'espace de travail (.tb/.rui) si vous l'avez personnalisé
  • Copiez les fichiers modèles que vous avez créés
  • Copiez tous les fichiers externes utilisés, tels que : les modules, les environnements, les scripts, etc.
  • Version 4 - Exportez les modes d'affichage personnalisés (si vous en avez créés) - en créant un fichier .ini par mode d'affichage

Sur la nouvelle installation :

Utilisez la commande ImporterOptions et importez le fichier .ini créé dans l'ancienne installation

  • Copiez vos fichiers d'espace de travail, de modèles, d'environnements, de scripts et de modules dans les emplacements correspondants.
  • Ouvrez le menu Outils > Configuration des barres d'outils et chargez votre espace de travail.
  • Déposez les fichiers des modules dans la fenêtre de Rhino pour les installer. (Certains ont besoin d'un fichier d'installation externe. Utilisez-le si nécessaire.)
  • Configurez Rhino pour qu'il s'ouvre avec votre fichier modèle personnalisé.
  • Dans la section Fichiers des Options, définissez les chemins d'accès aux scripts, aux fichiers modèles, etc. s'ils sont différents de ceux définis par défaut.
  • Dans la version 4 - Ouvrez le menu Options > Apparence > Paramètres avancés et importez les modes d'affichage personnalisés un par un.
fr/rhino/settingstransfer.txt · Last modified: 2021/07/13 by cecile