Site Tools


Transferring Personalized Settings

How to transfer all your personalized settings from one installation to another

Where are my settings stored?

In Rhino V5 and earlier most of Rhino's settings were not stored in external files, but in the registry. In Rhino V6, much of this info has been moved out of the registry into one or more .xml “settings” files. However, in both cases, as there is not one single file that contains all options and personalizations, it's not a one-click operation to transfer your custom settings from one install to another. Some shortcuts do exist:

The easiest way to transfer the bulk of your settings is to use the Rhino command OptionsExport (V5 and later), which creates a single file with most of the customizations. Importing this file into another installation via the command OptionsImport (V5 and later) will transfer the settings to the new install. You have a choice of which settings you would like to import. It is not necessary to import them all.

Note: In Rhino V4, the two commands above were named ExportOptions and ImportOptions. They were renamed in V5 to avoid confusion with other file import/export settings. Display modes are not included in the ExportOptions in V4, you need to export them separately. You do this from Options > Appearance > Advanced Settings.

Display modes are included in OptionsExport and OptionsImport from V5 on, but you can only import all of them at once (or none). If you want to just transfer individual display modes, use the Export/Import buttons in Options>View>Display Modes instead.

Separate from the other options, workspace files contain most of the info for toolbars/buttons such as which buttons are in which toolbar, command macros for each button and button images. Workspace files have the extensions .tb for V4, .rui for V5 and later. You can copy this file between installations as well. As of V5, the default location for these files is in a hidden folder:

C:\Users\<username>\AppData\Roaming\McNeel\Rhinoceros\<version number>\UI

(<username> represents your Windows account username, <version number> is 5.0, 6.0 etc.)

Note: You can access this quickly by hitting the Windows Start button and typing %appdata% and Enter which gets you to “Roaming”, then navigating to the appropriate folder.
For V4 installations, the toolbars are here: C:\ProgramData\McNeel\Rhinoceros\4.0 (Win Vista and later) or here: C:\Documents and Settings\All Users\Application Data\McNeel\Rhinoceros\4.0 (XP)

The workspace file does not contain the on-screen locations for the toolbars however, only the toolbars themselves and whether they are open or not. In V5, location info is still stored in the registry; in V6 it has been moved out to an .xml settings file which resides here:

C:\Users\<username>\AppData\Roaming\McNeel\Rhinoceros\6.0\settings

The .xml file containing the options mentioned at the beginning is in this same folder.

Finally, there are some other things that might have been personalized/modified. Among them could be your template files, installed plug-ins, etc. Template files are just .3dm files so they can be copied over without a problem; plug-ins probably need to be re-installed; beware of compatibility issues if you are upgrading to anew version of Rhino.

Umm, that sounds complicated, how do I make sure I get everything?

A general transfer procedure might look like this:

In the old install:

OptionsExport (or ExportOptions for V4) - creates an .ini file

  • Make a copy of your workspace (.tb/.rui) file if you customized it
  • Make copies of any custom template files you created
  • Make copies of any other external files used, including: non-standard plug-ins, e-maps, scripts, etc.
  • V4 - Export any custom display modes (if you created any) - creates one .ini file per display mode

In the new install:

OptionsImport (or ImportOptions for V4) and import the .ini file created above

  • Copy your workspace, template, emaps, scripts, plug-ins files to appropriate locations.
  • Go to Tools>Toolbar Layout and load your custom workspace.
  • Drag n' drop your extra plug-ins into the Rhino window to install. (Some need an external installer. Use that if necessary.)
  • Set Rhino up to open with your custom template.
  • In the Files section of Options, set file paths to scripts, templates, etc. if they are non-standard.
  • V4 - Go to Options > Appearance > Advanced Settings and import any custom display modes created, one by one.
rhino/settingstransfer.txt · Last modified: 2019/01/23 by mitch_heynick