Site Tools


转移个人设定

如何将个人设定从一个安装转移到另一个安装

我的设定储存在哪里?

大部分的Rhino设定不会存储在外部档中,而是在注册表中。没有一个单一档案能够包含所有个人化的设定与选项,所以您在转移自订设定的时候需要花点工夫,不过的确可以利用一些快捷的方法来进行:

想要将大量的个人设定转出,最容易的方法就是利用Rhino指令OptionsExport(5版),这个指令将您大部分的使用者自订资料建立成单一档案。利用OptionsImport(5版)将这个档案汇入新安装的Rhino。可以选择您想要汇入的设定,不一定要全部输入。

在Rhino 4版,这两个指令分别为ExportOptions以及ImportOptions,但在5版中这两个指令被重新改名,为了是与其他档案输入输出的设定做出区别。 Display Modes在4版并不包括在ExportOption里,您需要将它们分别汇出。从选项>外观>进阶设定 (Options >Appearance > Advanced Settings)。在5版,这些都包括在内,但您只能一次把它们全部汇入。如果您只想要转移个别显示模式,请使用选项 >视图 > 显示模式之下的汇出/汇入 。

工作区档 (workspace file) ( 4版是.tb,5版是.rui )包含所有工具列信息,使用者也可以将其转移至不同安装上。不过这个档案并不包括工具列在屏幕上的位置,只包括工具列本身以及它们是否开放。 在5版您可以自订功能表,.rui档也包含了功能档的信息。

其他可能被修改的包括您的模板档、显示模式还有安装的插件等等。

如何找到我的工具列档

5版使用者,您的工具列档在:
C:\Users\(username)\AppData\Roaming\McNeel\Rhinoceros\5.0\UI
这是在大多数Windows安装下的隐藏档,最简易的方法是在搜寻框中输入 %appdata%。

4版使用者,在Vista、Win 7或8系统中,您的工具列档在:
C:\ProgramData\McNeel\Rhinoceros\4.0
这也是一个隐藏资料夹,请在搜寻框中输入%programdata%。

在XP系统,工具列档在:
C:\Documents and Settings\All Users\Application Data\McNeel\Rhinoceros\4.0 or 5.0

这些步骤听起来有点复杂,我如何知道已经转移所有信息?

一般转移过程可能如下所示:

在旧的安装之下

OptionsExport(5版)或ExportOptions(4版) - 会建立一个.ini档

  • 请建立一个副本,如果是自订工作区档(.tb/.rui)的话。
  • 将任何自订模板档案建立副本
  • 制作其他外部档的副本包括非标准的外挂程序、电子地图、脚本等等。
  • 4版 - 输出任何自订显示模式 (如果有的话)- 每一个显示模式建立一个.ini档。

在新的安装之下

OptionsImport(5版)或ImportOptions(4版),并且汇入以上所建立的.ini档。

  • 将工作区、模板、电子地图、脚本、外挂程序复制到适当的位置。
  • 到工具>工具列配置并且载入自订工作区。
  • 将外挂拖曳到Rhino视窗,并开始安装(有些需要使用外部安装程序)
  • 以Rhino开启您的自订模板。
  • 在选项的档案部分,将档案路径设为脚本、模板等等,如果它们不在标准程序里。
  • 4版 - 请到选项>外观>进阶设定并且分别汇入不同自订显示模式。
zh/rhino/settingstransfer.txt · Last modified: 2016/10/04 by jessesn