Site Tools


Using RhinoCAM

Advice, tips, tricks and user experiences using the RhinoCAM plug-in.

For support questions about RhinoCAM and RhinoCAM Pro, please go directly to the MecSoft support forum.

MecSoft's RhinoCAM homepage.

For tutorials and videos, go to RhinoCAM tutorials.

Environment variables

Environment variables is a Windows feature that allows software manufacturers to configure certain options for the operating environment of their programs.

Create and access environment variables the following way: Right-click My Computer, select Properties, Advanced tab, Environment Variables. Add with the New button. These variables may be placed in the User section to have different possibilities for different users, or the System section to act globally for all users.

More info on using Environment Variables.

The following variables let you set certain options in RhinoCAM not directly accessible via options from inside the program.

  • VMILL_HFINISH_LEVELFIRST - 1/0 - Allows Level first machining in Horizontal Finishing
  • VMILL_ZTRANS_FFACTOR - [0.1-1.0] – Scales federates for plunge Z motions between Z levels in 2-1/2 axis operations
  • VMILL_SORT_PROFILES – [1/0] – Sorts profiles based on minimum distance to each other if set to 1
  • VMILL_DORETRACT_TABLEROTATE – [1/0] - Does retract to toolchange position before performing the table rotate if set to 1
  • VMILL_BEEP_TYPE - [0/1/2] 0 – Waveform beep, 1 – computer beep, 2 – No beep
  • VMILL_LICENSE_HOST – [IP Address] – Set to IP address of machine that has the network dongle for network licensing
  • VMILL_DISPLAYTOOLTIP - [1/0] - Displays a point at the tool tip during simulation if set to 1
  • VMILL_TOOLPATH_THICKNESS – [0.1-10.0] – OpenGL thickness value for displaying toolpath using thick lines


Using the user defined tool tab to create custom tools

Question: How is the user defined tool tab in the tool definition setup used? Is it possible to generate custom profile tools from tool drawings using this feature in RhinoCam?

Answer: User defined tools can be created and used in RhinoCAM in 2-1/2 axis profiling operations only. To create a user defined tool follow these steps:

  1. Draw the profile of the tool in the XY plane (only to the centerline, i.e. half profile).
  2. Make sure the starting point is at 0,0.
  3. In RhinoCAM 2.0, select the profile of the tool created in the XY plane from the Rhino menu bar use File→Export Selected and save this as a Rhino (*.3dm) file. Make sure that this is the only region in the file before exporting. This file will be the tool profile file. In RhinoCAM 1.0, save the file as .mrg (using export region in the file menu).
  4. In RhinoCAM 2.0, from the Cutting Tools Browser under the Create/Select Tools menu. Select the User Defined Mill tool. In RhinoCAM 1.0, in the Create/Select Tools menu, select **User Defined Mill tool.
  5. Select a name for the user-defined tool and enter the relevant information and comments. The parameter for the tool diameter should be twice the profile radius. You can also enter a different tool diameter if you need a different size tool. The system computes the tool diameter as twice the largest X coordinate in the tool profile. It will then scale the profile by (input diameter/computed diameter). Example: If the input diameter is same as computed diameter then the scale factor is one.
  6. Provide the path to the user-defined tool profile file.
  7. Save as a new tool.

Use the tool in 2-1/2 axis profiling operations.


To capture the active window with an image in RhinoCAM

ScreenCaptureToFile and ScreenCaptureToClipboard work fine in RhinoCAM to capture the active window with an image of a RhinoCAM simulation. ViewCaptureToFile/Clipboard does not work.


How to display a "Tool Guide" in VisualMill

Go in to your registry, open up HKEY_CURRENT_USER folder, scroll down to the Software folder and open it. Next find Mecsoft Corporation folder and open it. Find the settings folder and open it. Find the DisplayToolAtCursor reg_dword, double-click on it and change the value data from a 0 to a 1.

Now it will display the tool you have loaded while making a boundary or creating geometry.

rhino/rhinocam.txt · Last modified: 2016/05/17 by sandy