Site Tools


The Importance of Saving Your Custom Work Environment

Note: the following does not apply to Rhino for Mac.

Under Windows, Rhino's toolbars are stored in a special file generally called a workspace file. The default workspace file is named default.rui for Rhino 5 or later, or default.tb for Rhino 4 and earlier. (rui=Rhino User Interface ; tb=ToolBar)

Any changes you make to the toolbars - such as adding/changing macros or scripts, adding buttons, etc. are normally only written to the workspace file when Rhino closes. (it is possible to force a save earlier, more on that below).

As you can have multiple instances of Rhino open at the same time, if you are not careful, it is easy to get into a situation where you might lose your customizations. All it takes is to have two instances of Rhino open, to make changes in one, but close that first. When the second instance of Rhino without the changes is closed, it will overwrite the first, and any changes will be lost.

Therefore, if you have changed the default workspace file in any significant way, and you want to keep your changes, be sure to save it under a new name!

Note also: if Rhino 4 is uninstalled, the default workspace file is deleted - which will wipe out all your customization in an instant. In Rhino 5 or later, you will not lose the default workspace file when Rhino is uninstalled or updated. But, workspace files may still get corrupted and hence unusable on rare occasions. Using the command ToolbarReset will also replace the existing default file, and any customization made to it will be lost as well.

How to save your customizations

Go to Tools > Toolbar Layout (or Options > Toolbars), highlight the default file in the upper right window, then click File > Save As from the menu and give your changed workspace a new, recognizable name. Now continue to use this file for your work.

The .rui files in V5 and later are stored in the following folder:

C:\Users\<username>\AppData\Roaming\McNeel\Rhinoceros\5.0 (or 6.0)\UI  

AppData is a hidden folder, to get there, at the Windows start button, type %appdata% and Enter, you can then navigate from there.

Always do all your modifications on your custom workspace. We recommend that you save this file somewhere else as well as a backup (preferably on another computer, like all important documents). Think of how much time it will take you to recreate your file if you lose it.

Installing Rhino updates or using ToolbarReset will not affect your personalized workspace file.

Important

Make sure only one instance of Rhino is open when making toolbar/workspace modifications! Once done with your toolbar installations, make sure you use File>Save from the toolbar layout dialog to save your changes! Or, exit Rhino and reopen. Rhino saves toolbar changes automatically on exit. If you have multiple instances of Rhino open, the last one to close will overwrite the previous one, so you might lose your changes.

Settings not included in Rhino workspace files

The workspace file only contains information related to toolbars, not to other Rhino options. For a complete overview of where all the Rhino options are stored and how to back them up or transfer them, see this page.

The above info applies to Rhino 6 and earlier. Some of it may change for future versions.

rhino/saveyourworkspace.txt · Last modified: 2020/08/14 (external edit)